httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim Walls <k6...@earthlink.net>
Subject Re: [users@httpd] Newbie Problems: Webpage quick load fromserver and LAN computers, slow load from external computers
Date Sun, 03 Nov 2002 22:26:45 GMT
> >I just became a Linux user and thought I'd make one of my first missions
> >to create and host my own website.  My first mission was to configure
> >and start Apache 1.3.26 on Suse 8.1 Linux.  After a couple misguided
> >attempts, I was able to load a sample page from the server and from
> >another computer on the LAN.  I then loaded a simple web page (made with
> >Dreamweaver MX) my wife created into htdocs and this also seems to load
> >fine from the server and other LAN computers.  The problem I run into is
> >when friends and family try to load the page.  The text seems to load
> >just fine, but the one picture on the page takes FOREVER to load (maybe
> >5 minutes).  This is really disconcerting since the page loads in about
> >1 second for me when accessed from my notebook.  Does anyone have an
> >idea as to why this might be happening?  Below is a quick run down of
> >how I have things set up on my network and web server.

Loading fine now, but I see you took out the spaces as several people suggested.

> >I have a dynamic IP address from Southwestern Bell.  I resolve this by
> >utilizing a nice little utility/service called No-IP (www.no-ip.com
> ><http://www.no-ip.com/> ), which constantly monitors my IP address and
> >points my domain name (www.benjieandjulie.com
> ><http://www.benjieandjulie.com/> ) to the router IP address.  I then
> >have a Linksys router with port 80 forwarded to my local web server IP
> >address.  The picture on the web page is approx. 22Kb and the total page
> >is about 30Kb.  From what I can gather on the upload bandwidth tests
> >I've done I'm getting about 100Kbps.  This should be fast enough to load
> >the full page in about 2-3 seconds.  The text loads very quickly (as
> >expected), but then the browser just sits and spins waiting for the
> >picture to load.  If anyone has any suggestions I'm all ears!  I've been
> >trying to figure out why computers on the LAN can load the page so
> >quickly while outside computers struggle.  It would make sense if they
> >requested the page directly through the LAN, but if I type in
> >www.benjieandjulie.com <http://www.benjieandjulie.com/>  shouldn't they
> >go outside the network to request the IP address from the No-IP DNS just
> >like everyone else?

I'm also running a dynamic DNS on my server at home (http://www.k6ccc.org) using DNS2Go with
a
LinkSys router so except that we are using different DNS providers, that portion of our systems
are similar.  I believe that your router is being smarter than you are.  When a client browser
requests the DNS entry for your site, it get's the IP address of the WAN side of your router
from
the DNS server.  When the browser then send a request for the page on that IP address, the
router
realizes that it's pointing to itself and the remainder of the communication between the web
server and the browser never leaves your LAN.

-----------------------
Jim Walls - K6CCC
k6ccc@amsat.org
http://home.earthlink.net/~k6ccc/
626-302-8515    FAX  626-302-7501
AMSAT member 32537 / WSWSS member 395



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message