httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From pi...@goldfisch.at
Subject Re: [users@httpd] strange behaviour of mod_vhost_alias
Date Wed, 20 Nov 2002 23:58:24 GMT
On Wed, Nov 20, 2002 at 11:12:41AM -0500, Joshua Slive wrote:
> 
> Wait a second; one more idea:  Try adding
> ServerName not.a.host
> to the <VirtualHost> section containing the VirtualDocumentRoot.
> 
> I think I know what apache is doing.  Since there is no ServerName in that
> VirtualHost, apache is doing a reverse lookup on the IP address to supply
> the ServerName.  That is why it is catching the canonical name.
> 
> That must be the answer.  I don't know why I didn't think of that before.
> 

As the last time you helped me on this list you are perfectly
right. This solved my problem.

I added an full explanation of this problem to my private knowledgebase 
(http://www2.goldfisch.at/knowledge/179) for further reference.


I want to express my great thanks for your assistance. It just great
finding such professional and helpful assistance in this (and other)
mailinglists.

peter


-- 
mag. peter pilsl
IT-Consulting
tel: +43-699-1-3574035
fax: +43-699-4-3574035
pilsl@goldfisch.at
http://www.goldfisch.at

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message