httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Williamson <dav...@certaintysolutions.com>
Subject [users@httpd] DSO support problems on Solaris 9.
Date Thu, 14 Nov 2002 18:22:46 GMT
I'm having trouble with apache 1.3.27 on Solaris 9.  I have a pretty
simple build environment, and I'm using gcc 3.2.  I was trying to do
something fairly complex with mod_ssl, php, and mod_perl, but since I
was having trouble, I tried to do something simple.  I un-tar'd a new
build tree, and built a trivial configuration:

$ ./configure
$ make
$ sudo make install
$ sudo /usr/local/apache/bin/apachectl start
$

That works fine.  But what I'd really like to do is use DSO support,
so I used a configuration listed in README.configure:

$ ./configure --prefix=/path/to/apache --enable-module=most --enable-shared=max
$ make
$ sudo make install
$ sudo /usr/local/apache/bin/apachectl start
Syntax error on line 205 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/mod_env.so into server: ld.so.1: /usr/loca
l/apache/bin/httpd: fatal: relocation error: file /usr/local/apache/libexec/mod_
env.so: symbol ap_palloc: referenced symbol not found
/usr/local/apache/bin/apachectl start: httpd could not be started

If I do any configuration involving DSO support, I get this same error.
As ap_palloc is an internal function, and the library for it should be
statically linked in the first place, I don't understand this error.
I have a Solaris 8 box with a similar configuration that works just fine.

Anyone have any suggestions?

-David


--
David Williamson                |       "Wine is light, held
Certainty Solutions, Inc.       |        together by water."
davidw@certaintysolutions.com   |                   -Galileo

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message