httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Zac Stevens <...@cryptocracy.com>
Subject Re: [users@httpd] I get error when defining <Directory></Directory> in win2k workstation
Date Thu, 07 Nov 2002 14:22:20 GMT
On Thu, Nov 07, 2002 at 10:42:03AM -0300, Marcelo Laia wrote:
> [line 1] php_value auto_prepend_file	php_value_ok.php
> [line 2] php_flag magic_quotes_gpc off
> 
> [line 3] Options FollowSymLinks
> [line 4] <IfModule mod_rewrite.c>
> [line 5] RewriteEngine On
> [line 6] RewriteRule ^(index.php)$		
> index.php?init_mod_rewrite=1&ampersandbroken=    [QSA]
> [line 7] </IfModule>
> 
> When I put in the httpd_conf:
> 
> <Directory C:\webdoc\gallery>
>       AllowOverride None
>       Options FileInfo Indexes
> </Directory>

I seem to recall that DOS-format paths should be quoted. eg,

<Directory "C:\webdoc\gallery">

Does that make a difference?

I suspect the problem is that you cannot set php_flag's (or that particular
one) from within a Directory context.  You could try putting it into the
main server (or virtualhost) config instead, or into an external php.conf
file.  In any event, that's a question for a PHP list.

HTH,


Zac

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message