httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Justin Williams" <jus...@naturalwebs.com>
Subject Re: [users@httpd] HTTPS?
Date Fri, 15 Nov 2002 16:55:34 GMT
I'm not sure that I understand

there are a number of name-based virtual domains for .13
.18 is the only IP based.  Do I need to create an ip-based .13 as well?

Then, in the following:
<VirtualHost 206.28.133.18:443>
DocumentRoot /home/securesite/www
ServerName ***
SSLEngine on
SSLCertificateFile /home/securesite/securesite.pshift.com.crt
SSLCertificateKeyFile /home/securesite/securesite.pshift.com.key
DirectoryIndex index.html
</VirtualHost>

What include am I putting in?  There is an include to
Include  conf/ssl/mod_ssl.conf
Include  conf/ssl/ssl.default-vhost.conf
in httpd.conf, already.
The second include has the default ssl information.  Do I need to create
*another* Virtual Host in there?

----- Original Message -----
From: "Remo Mattei" <remo@italy1.com>
To: <users@httpd.apache.org>
Sent: Friday, November 15, 2002 11:35 AM
Subject: RE: [users@httpd] HTTPS?


> Did you try to create a virtual domain for the 13? And then for the 18?
> You need to copy the ssl portion and use the include in the ssl for the
> 18.
>
> Remo
>
> -----Original Message-----
> From: Justin Williams [mailto:justin@naturalwebs.com]
> Sent: Friday, November 15, 2002 9:30 AM
> To: users@httpd.apache.org
> Subject: [users@httpd] HTTPS?
>
> This may or may not be the right place to post this; I think it is but,
> please tell me if not.
>
> I have two IPs on the same NIC.  .13 and .18
> .18 (on eth0:1) is reserved for an IP-based virtual domain, which is set
> up
> in the conf listening only on :443.
> .13 (on eth0) is everything else.
>
> I have gotten my CRT from Verisign and placed that into the directory
> where
> I want it to be.
> I have the cert and key referenced in the conf file.
>
> If I go to http://IP.18, the most recently configured domain on .13 pops
> up.
> If I go to https://IP.18, I get page could not be displayed.
>
> Bummin' and tryin' to figure out what I am missing.  From what I have
> been
> reading, I have done all the right stuff, but, obviously, I am
> forgetting or
> missing *something*  Can somebody point me in the right distraction?
> Thanks!
>
>
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server
> Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>    "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>
>
>
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>    "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message