httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sebastien Bellerive" <seb....@sympatico.ca>
Subject [users@httpd] Re: Startup error with apache 2.0.43
Date Sat, 23 Nov 2002 20:14:30 GMT
What, has no one any ideas on this?  Or is the solution something so stupid that no one is
bothering to answer?  

Seb


  ----- Original Message ----- 
  From: Sebastien Bellerive 
  To: users@httpd.apache.org 
  Sent: Wednesday, November 20, 2002 7:12 PM
  Subject: Startup error with apache 2.0.43


  Hello list,
    I have a problem with apache starting up that has me stumped.

  As with many people, I get this:

  "[emerg] (22)Invalid argument: Couldn't set permissions on cross-process lock; check User
and Group directives"

  Now before someone says anything about past posts on this, please note that I HAVE read
them and tried their solutions.

  I HAVE set the User and Group to valid ones.  I have tried to use the AcceptMutex directive.

  First off, I tried:
  User nobody
  Group nobody

  Then tried Group nogroup and #1 (don't ask, some post i found in some newsgroup)

  I even tried making a new user and group (www and www).
  None of that worked.

  (my apache 1.3.9 ran as User nobody, Group nogroup)

  With the AcceptMutex directive, I tried switching to flock, fnctl and sysvsem.   Both flock
and fnctl make the error in the logs not appear, but the httpd doesn't start.  No errors.
 It just appears as "httpd -k start" in ps, then vanishes with no messages anywhere.  (even
with "-e debug" as a command line option)

  I even tried setting the permissions on the logs dir (where the lock file is) to 777

  Now, down to some technical details...

  # ./bin/httpd -V
  Server version: Apache/2.0.43
  Server built:   Nov 20 2002 01:16:14
  Server's Module Magic Number: 20020903:0
  Architecture:   32-bit
  Server compiled with....
   -D APACHE_MPM_DIR="server/mpm/prefork"
   -D APR_HAS_SENDFILE
   -D APR_HAS_MMAP
   -D APR_HAVE_IPV6
   -D APR_USE_SYSVSEM_SERIALIZE
   -D APR_USE_PTHREAD_SERIALIZE
   -D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
   -D APR_HAS_OTHER_CHILD
   -D AP_HAVE_RELIABLE_PIPED_LOGS
   -D HTTPD_ROOT="/usr/local/apache2"
   -D SUEXEC_BIN="/usr/local/apache2/bin/suexec"
   -D DEFAULT_PIDLOG="logs/httpd.pid"
   -D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
   -D DEFAULT_LOCKFILE="logs/accept.lock"
   -D DEFAULT_ERRORLOG="logs/error_log"
   -D AP_TYPES_CONFIG_FILE="conf/mime.types"
   -D SERVER_CONFIG_FILE="conf/httpd.conf"

  # uname -m -r -s -p -v
  Linux 2.2.14 #1 Fri Sep 14 21:20:05 EDT 2001 i586 unknown 

  Apache is installed in the default location, with the default permissions (installed as
root)

  help! heh

  Sebastien Bellerive

Mime
View raw message