httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dan Stephens" <DanielBSteph...@hotmail.com>
Subject Re: [users@httpd] installation trouble
Date Wed, 22 Oct 2003 17:27:48 GMT
Ok, I reinstalled the tarball after I thought I unstalled the same version. At best I thought
I may just be copying over apache-2.0.40 with itself. Everything went ok till i did

[root@mail root]# /usr/local/apache2/bin/apachectl start
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80 
no listening sockets available, shutting down

Now I understand this to mean that something is already allotted to port 80, but when i do
a % netstat -an | grep LISTEN , port 80 isn't shown like there is anything bound to it. 
I hope some of this makes sense to some of you, thanks,
   Dan 
  ----- Original Message ----- 
  From: Dan Stephens 
  To: users@httpd.apache.org 
  Sent: Wednesday, October 22, 2003 10:38 AM
  Subject: [users@httpd] installation trouble


      I'm running RH 7.2 on my server and was running 1.3.something. I then tried to upgrade
to 2.0.4 and in the completion of it have run into some serious problems. 

  -I installed httpd-2.0.40 from a tarball and I think I did it correctly (tar xvf, make,
make install, make clean, ./configure), but my box still doesn't seem to be able to find it
(service start httpd comes back with httpd isn't installed
  -I have uninstalled 1.3.whatever successfully, but now my /etc/init.d/httpd file isn't looking
to my new version of httpd, not that my box even recognizes the new httpd installed at all.

  -I am a bit frustrated, as this has been a problem i've had nagging me for quite some time,
if anyone could explain to me how to install httpd correctly from a tarball, including how
to make the box recognize and start it, please let me know, thank you very much,
     Dan

Mime
View raw message