httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jason Wilkinson" <ja...@wilknet.com>
Subject [users@httpd] Omitting certain file from logs (conditional logging) not working correctly
Date Thu, 17 Oct 2002 21:26:12 GMT
Hi all,

I'm having a problem. One certain file on our server needs to be omitted
from the logs as its frequent access is skewing our log files. It seems
as if the best method for this is to use SetEnvIf to filter it out. I've
been able to get it to filter these requests out into a separate log
file, but for some reason it STILL logs it into the main access_log file
as well. I've RTFM, and that is how I've set it up below. Does anybody
have any ideas why it would still be placing these entries into the main
log file as well as the filtered log file?

Thanks in advance for any help.

-jw-

<snip from httpd.conf>
SetEnvIf Request_URI "upload_status" dontlog
CustomLog /home/httpd/logs/dont_log common env=dontlog
CustomLog /home/httpd/logs/access_log combined env=!dontlog
</snip from httpd.conf>

-subsequent entry from /home/httpd/logs/access_log

vhost.server.com 192.168.0.100 - - [07/Oct/2002:11:58:47 -0500] "GET
/demo/domain.com/upload_status.html?id=878a8325fef868dc66ed055cef28d755
HTTP/1.1" 200 572 "-" "Mozilla/4.0 (compatible; MSIE 5.5; Windows NT
5.0; T312461)"

-subsequent entry from /home/httpd/logs/dont_log

192.168.0.100 - - [07/Oct/2002:11:58:47 -0500] "GET
/demo/domain.com/upload_status.html?id=878a8325fef868dc66ed055cef28d755
HTTP/1.1" 200 572
 

Mime
View raw message