httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sou...@netscape.com (Souvik Das)
Subject [users@httpd] Error on Apache2.0 startup
Date Mon, 14 Oct 2002 23:53:33 GMT
Hi,
    I have written my own module and have added it to the httpd.conf 
file. When I start up my Apache 2.0.40 server (Red Hat linux) I get an 
error.

    *    This is the error that I get on startup

---------------------------------------------------------------
Syntax error on line 260 of /usr/local/apache2/conf/httpd.conf:
API module structure `my_module' in file /usr/my_module/VlApache.so is 
garbled - perhaps this is not an Apache module DSO?

---------------------------------------------------------------

    *    The lines in my httpd.conf file look like this
   
    LoadModule my_module /usr/mymodule/MyApache.so
    MyConfigFile  /usr/mymodule/my.conf

    * My code looks like this.

module AP_MODULE_DECLARE_DATA my_module = {
    STANDARD20_MODULE_STUFF,
    my::CApacheMain::CreateDirConfig, // create per-directory config 
structure
    my::CApacheMain::MergeDirConfig,  // merge per-directory config 
structure
    my::CApacheMain::CreateConfig,    // create per-server config structure
    my::CApacheMain::MergeConfig,     // merge per-server config structure
    my::CApacheMain::m_configCmds,    // command table
    my::CApacheMain::register_hooks,  // register hooks
};


    Is there something wrong that I am doing? Any help would be greatly 
appreciated.
    Thanks

-souvik


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message