httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From lists <li...@linuxprofessional.net>
Subject [users@httpd] Authentication on Apache 2.0.40
Date Fri, 11 Oct 2002 00:44:29 GMT
Authentication fails on Apache 2.0.40.  I've read through the 
installation and configuration instructions a number of times.  I have 
authentication working using .htaccess files on Apache 1.3.  

I am prompted for the user name and password; however, authentication 
just fails.  I'm trying to use Directory authentication (as opposed to 
.htaccess).  I am certain I have followed the instructions step-by-step. 
 My httpd.conf files includes the following:

<Directory />
    Options FollowSymlinks
    AllowOverride AuthConfig
</Directory>

<Directory /usr/local/apache2/www>
    AuthType Basic
    AuthName "Restricted Files"
    AuthUserFile /usr/local/apache2/passwd/passwords
    Require user michael
</Directory>

I understand that the module mod_auth is a base module and is included 
by default with the installation unless it is specifically disabled.  I 
created the passwords file by following the in the documentation and 
have verified it exists.  I'm running this on SuSE 7.3 Professional.  I 
have PHP 4.2.2 and MySQL 3.23.52 running as well.  All works great 
except authentication.

Anyone have any ideas?

Michael


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message