httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cindy Ballreich <ci...@ballreich.net>
Subject Re: [users@httpd] Apache 1.3.27 Segmentation Faults
Date Wed, 09 Oct 2002 16:10:02 GMT
At 10:21 PM 10/8/02 -0400, William C. (Bill) Jones wrote:
>On Tuesday, October 8, 2002, at 04:18  PM, Matthew Daubenspeck wrote:
>
>> $ apache -l
>> Compiled-in modules:
>>   http_core.c
>>   mod_so.c
>>   mod_macro.c
>> suexec: enabled; valid wrapper /usr/lib/apache/suexec
>
>
>Interesting, mod_so is enabled.  Are there any DSO (libexec) 
>entries in your httpd.conf that would load mod_perl or mod_php, 
>etc?  Possibily another module is misbehaving.
>

Mine is similar except that suexec is not enabled and I don't have any modules compiled in...
httpd -l
Compiled-in modules:
  http_core.c
  mod_so.c
suexec: disabled; invalid wrapper /usr/local/apache/bin/suexec

You've mentioned mod_php and mod_perl a couple of times in this thread. I don't understand
why these would have anything to with this problem, but I do use libphp4.so. Perhaps this
is useful: with apache 1.3.26, I had been using the version of libphp4.so from the RedHat
rpm for php-4.1.2-7.3.4. It worked great with 1.3.26. After installing 1.3.27, I ran configtest
and got the error: "API module structure `php4_module' in file /usr/lib/apache/libphp4.so
is garbled - perhaps this is not an Apache module DSO?" So I built and installed php-4.2.3,
and then rebuilt apache with config directives to enable and share that module. Here's the
config.status so you can see how it was built... 
./configure \
"--with-layout=Apache" \
"--prefix=/usr/local/apache" \
"--enable-rule=SHARED_CORE" \
"--activate-module=src/modules/php4/libphp4.a" \
"--enable-module=most" \
"--enable-shared=max" \
"--logfiledir=/var/log/httpd" \
"--server-uid=apache" \
"--server-gid=apache" \
"--enable-module=php4" \
"--enable-shared=php4" \
"$@"

Other than the php4 stuff, this is identical to the way I had built 1.3.26.

We've determined that the security problems fixed by 1.3.27 aren't threats to our server,
so our plan is to go back to 1.3.26. However, I'd still like to know what's going on with
this. Is it possible that a segmentation fault from RedirectMatch in mod_alias could somehow
be caused by the PHP module?

Thanks

Cindy

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message