httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bioinfo Gu <bioinfowis...@yahoo.com>
Subject [users@httpd] Loaded DSO libexec/libphp4.so uses plain Apache 1.3 API, this module might crash under EAPI! (please recompile it with -DEAPI)
Date Thu, 31 Oct 2002 15:01:10 GMT

Hello,

I am install apache_1.3.27 enable mod_ssl, with the following:

openssl_0.9.6g

mm-1.1.3

mod_ssl-2.8.11-1.3.27

apache_1.3.27

php-4.0.6

I have followed the instruction which is built in mod_ssl-2.8.1-1.3.27 package. The compile
and install are all successful.  I use :

cd mod_ssl-2.8.11-1.3.27
# ./configure --with-apache=../apache_1.3.27 --with-ssl=../openssl-0.9.6g --with-mm=../mm-1.1.3
--prefix=/compbio/programs/apache_1.3.27 --enable-shared=ssl --enable-module=most --enable-shared=max
--with-port=8080 
cd ../apache_1.3.27

make

make certificate

make install

All these steps are successful.

After I 'make install', try 'apachectl startssl', it is fine. But when I add "

LoadModule php4_module        libexec/libphp4.so" this line into httpd.conf, 

and then ./apachectl startssl again,  it will give me warning, and I can not display php pages:

# ../bin/apachectl startssl
[Wed Oct 30 18:33:50 2002] [warn] Loaded DSO libexec/libphp4.so uses plain Apache 1.3 API,
this
module might crash under EAPI! (please recompile it with -DEAPI)
Apache/1.3.27 mod_ssl/2.8.11 (Pass Phrase Dialog)
Some of your private key files are encrypted for security reasons.
In order to read them you have to provide us with the pass phrases.

Server athena.wistar.upenn.edu:443 (RSA)
Enter pass phrase:

Ok: Pass Phrase Dialog successful.
../bin/apachectl startssl: httpd started


Thank you very much.

Grace



---------------------------------
Do you Yahoo!?
HotJobs - Search new jobs daily now
Mime
View raw message