httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Patrick Harlin <pat...@dc.luth.se>
Subject [users@httpd] Berkley DB4 with apache 1.3.27 compiling...
Date Tue, 29 Oct 2002 09:45:06 GMT

When I run the apache configure script I get following:

 using Berkeley-DB/3.x for mod_auth_db (-ldb)
    o ssl_module uses ConfigStart/End

So it looks like it doesn't find the Berkley DB4 libs or includefiles, even 
though I explicitly gave the location to Configure ? See below:
# more Configure_1.3.27.sh 
#! /bin/sh
cd /soft/build/apache_1.3.27
EAPI_MM="/soft/mm/1.2.1"
export EAPI_MM
SSL_BASE="/soft/openssl/0.9.6g"
export SSL_BASE

INCLUDES="-I/sof/openssl/0.9.6g/include -I/usr/local/BerkeleyDB.4.1/include"
export INCLUDES
LDFLAGS="-L/soft/openssl/0.9.6g/lib -R/soft/openssl/0.9.6g/lib 
-L/usr/local/BerkeleyDB.4.1/lib -R/usr/local/BerkeleyD
B.4.1/lib -L/soft/apache/1.3.27/lib -R/soft/apache/1.3.27/lib"
export LDFLAGS

./configure                                                     \
        --prefix=/soft/apache/1.3.27                            \
        --enable-rule=SHARED_CORE                               \
        --enable-rule=PARANOID                                  \
        --enable-module=access                                  \
        --enable-module=actions                                 \
        --enable-shared=actions                                 \
        --enable-module=alias                                   \
        --enable-module=asis                                    \
        --enable-shared=asis                                    \
        --enable-module=auth                                    \

...


When I am trying to compile with the make command I get following:


gcc -c -I/soft/mm/1.2.1/include -I../../os/unix -I../../include 
-I/soft/openssl/0.9.6g/include -I/usr/local/BerkeleyDB.4.1/include  
-DSOLARIS2=280 -DMOD_SSL=208111 -DEAPI -DEAPI_MM -DUSE_EXPAT 
-I../../lib/expat-lite -fPIC -DSHARED_CORE `../../apaci` -DSHARED_MODULE 
mod_auth_db.c && mv mod_auth_db.o mod_auth_db.lo
mod_auth_db.c: In function `get_db_pw':
mod_auth_db.c:175: warning: passing arg 2 of pointer to function from 
incompatible pointer type
mod_auth_db.c:175: warning: passing arg 4 of pointer to function makes pointer 
from integer without a cast
mod_auth_db.c:175: too few arguments to function
*** Error code 1
make: Fatal error: Command failed for target `mod_auth_db.so'

I think the cause of all this is that I didn't manage to include the correct 
db.h file, and this should then prove my assumtion that the configure went 
wrong. But what is the problem ? Any suggestions would be appreciated.

/Cheers,

Patrick 


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message