httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Werner Schalk" <werner_sch...@gmx.de>
Subject RE: [users@httpd] Problems with AssignUserID
Date Sat, 12 Oct 2002 13:10:01 GMT
Hello,

well I would like to test perchild
and I have set these directives:

User nobody
Group nogroup
AcceptMutex fcntl

<VirtualHost 192.168.0.1>
ServerName www.example.com
DocumentRoot /usr/local/apache2_perchild/htdocs
ServerAdmin webmaster@dummy-host.example.com
ErrorLog logs/dummy-host.example.com-error_log
CustomLog logs/dummy-host.example.com-access_log common
AssignUserId nobody nogroup
ChildPerUserId nobody nogroup 1
</VirtualHost>

Now when I try to start the server I get
the following error message:

Syntax error on line 1038 of
/usr/local/apache2_perchild/conf/httpd.conf:
Unable to find process with matching uid/gid.

Why any hints? How to use AssignUserId or
ChildPerUserId? Is there a way to let a child
run under the user werner? User nobody and
group nogroup do exist and if I take
the AssignUserId and ChildPerUserId out off
httpd.conf it works...

Bye and thanks,
Werner


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message