httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rich Bowen <rbo...@rcbowen.com>
Subject Re: [users@httpd] CGI-Problems
Date Mon, 30 Sep 2002 10:37:16 GMT
On Mon, 30 Sep 2002, Paul Tritscher wrote:

> Hi all!
> I have a big problem with the configuration of CGI on my System!
> I know the basics about how to configure CGI but this is a bit special!
> My DNS-Server tells: admin.example.com should point to a
> Virualhost-Directory /home/www/example.com/cgi-bin! In did a
> directory-index on cgi-bin to open lets say the script "admin"! All of
> this would be no problem if the "admin"-script would have an extension:
> admin.cgi - then is works fine but unfortunately it doesn't have any
> .cgi or the like. Now i did a <Location /cgi-bin> SetHandler cgi-script
> </Location> which also works fine but only if i configure my Vhost that
> I have to put in "admin.example.com/cgi-bin" but I want my
> "admin"-script to run without giving a directory (admin.exmaple.com
> should run the script)! Hope you know what I mean!

If I have correctly understood what you want ...

First, you need to "SetHandler cgi-script" for the main directory of your
site, and then you need to "DirectoryIndex admin" in order to get that
file to run when the site is requested.

-- 
Oh I have slipped the surly bonds of earth
And danced the sky on laughter-silvered wings
 --High Flight (John Gillespie Magee)


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message