httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthew Warren" <wazisonl...@hotmail.com>
Subject [users@httpd] IE closing connection with PERL CGI output
Date Sun, 22 Sep 2002 16:27:44 GMT
This is a sensible re-post of my previous problem.


Hi People,

I have a problem when trying to recieve perl generated output called with
<!--#include virtual from within an HTML file asked for by IE.

IE Appears to continually re-load the page in quick succession before
either;

displaying the page ok (rarely)
displaying the page corrupted (now and again)
returning 'This page cannot be displayed' error (Most of the time)


I have tried the following;

Get the page to load, save from IE as .html or .mht. The page loads Ok into
iexplorer every time.

Run the perl CGI script from a cmd window, it runs ok every time.


I have set the Apache errorlogging level to debug, I get the following in
the Apache error log;

[Sun Sep 22 17:13:38 2002] [info] (32554)An existing connection was forcibly
closed by the remote host.  : core_output_filter: writing data to the
network
[Sun Sep 22 17:13:38 2002] [info] (32554)An existing connection was forcibly
closed by the remote host.  : core_output_filter: writing data to the
network
[Sun Sep 22 17:13:38 2002] [info] (32554)An existing connection was forcibly
closed by the remote host.  : core_output_filter: writing data to the
network
[Sun Sep 22 17:13:38 2002] [info] (32554)An existing connection was forcibly
closed by the remote host.  : core_output_filter: writing data to the
network
[Sun Sep 22 17:13:38 2002] [info] (32554)An existing connection was forcibly
closed by the remote host.  : core_output_filter: writing data to the
network
[Sun Sep 22 17:13:38 2002] [info] (32554)An existing connection was forcibly
closed by the remote host.  : core_output_filter: writing data to the
network
[Sun Sep 22 17:13:39 2002] [info] (32554)An existing connection was forcibly
closed by the remote host.  : core_output_filter: writing data to the
network


I will recieve lots of these lines whenever the page tries to load and
fails.


The environment is;
Apache 2.0.39, ActivePERL, Win XP Pro fully updated as per MS auto-updates.
IE6.

The Apache server, ActivePERL and IE6 are all running on the same machine.
The same problems occurr if I use a different machine with the same IE
version elsewhere on the LAN.


The simplest perl script I have that exhibits this problem is the following;
(No work of art, etc..)

#!C:\Program files\perl\bin\perl.exe

@playlistfolders=("c:\\mymusi~1\\softer\\","C:\\mymusi~1\\harder\\");


foreach $dirname (@playlistfolders)
{
 opendir(LISTDIR,$dirname);
 @entries=readdir(LISTDIR);
 closedir(LISTDIR);
 @mp3s = @entries;
 @filtered = grep(/\.mp3$/, @mp3s);
 foreach $song (@filtered)
 {

   $song =~ s/\.mp3/ /g;
   $song =~ s/\.wav/ /g;
   print '<input type="checkbox" name="';
   print "$song";
   print '" value="checkbox">';
   print "$song";
   print '<br clear="left">';

 }

}



Any help would be much appreciated. It's killing me trying to write and test
a perl script when IE keeps screwing up!


Thanks,

Matthew.



---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.391 / Virus Database: 222 - Release Date: 19/09/2002

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message