httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <Daniel.T.Hellstr...@telia.se>
Subject SV: SV: SV: [users@httpd] make files accessible without index.html file
Date Fri, 27 Sep 2002 11:36:44 GMT
One more thing Zac

These changes:
<Location /pia>
Options +Indexes
</Location>

<Directory /home/pia/public_html>
Options +Indexes
</Directory>

Will allow me to access /~pia and /pia whether there is an index.html file in it or not, but
how do I do it if I want these settings to work for all users ?

/Dan

> ---------------------------------------------------------------------------
> Daniel Hellstrand
> Telia Mobile, R & D
> Services Design 
> 
> Address:
> Klökanvägen 8
> SE-851 87 Sundsvall
> Sweden
> 
> Phone: +46 60 14 53 75
> Mobile: +46 70 682 13 85
> 
> E-mail: daniel.t.hellstrand@telia.se
> 
> http://www.telia.se/mobile
> 


-----Ursprungligt meddelande-----
Från: Zac Stevens [mailto:zts@cryptocracy.com]
Skickat: den 27 september 2002 10:42
Till: users@httpd.apache.org
Ämne: Re: SV: SV: [users@httpd] make files accessible without index.html
file


On Fri, Sep 27, 2002 at 10:34:37AM +0200, Daniel.T.Hellstrand@telia.se wrote:
> The only thing I have added in /etc/httpd/conf/httpd.conf is:
> ---
> <Directory /home/pia/public_html>
> Options +Indexes
> </Directory>
> 
> UseCanonicalName Off
> ---
> 
> And the userdir I´m trying to access is of course "pia"

ahh but it's not just what you've added, but also what is there to begin
with.

I am assuming that the <Directory> block for your DocumentRoot
(/var/www/html ?) has FollowSymLinks but not Indexes set in its Options,
and that although Apache is correctly traversing the symlink it is applying
the Options relevant to the source of the symlink, rather than the target.

All that being correct, you can probably solve your problem by adding

<Location /pia>
Option +Indexes
</Location>

Haven't tested this, but it should work.

Another option is to use an Alias instead of a symlink at the filesystem
layer.  Try removing the symlink and adding

Alias /pia/ "/home/pia/public_html/"

to your configuration.

HTH,


Zac

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message