httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andy Bierlair" <a...@root.lu>
Subject [users@httpd] Failure in Apache 2.0.40 with perchild module
Date Sat, 21 Sep 2002 21:15:04 GMT
I have recently tried to configure apache 2.0.40 with the perchild
module since this is the right solution for what I need with
virtualhosting. Compilation works just fine but I am having big trouble
starting apache after the new compilation.

This is what my error log says:

[Sat Sep 21 22:35:36 2002] [notice] child pid 32406 exit signal
Segmentation fault (11)
[Sat Sep 21 22:35:36 2002] [emerg] (13)Permission denied:
apr_proc_mutex_lock failed. Attempting to shutdown process gracefully.
[Sat Sep 21 22:35:36 2002] [emerg] (13)Permission denied:
apr_proc_mutex_unlock failed. Attempting to shutdown process gracefully.
[Sat Sep 21 22:35:36 2002] [emerg] (13)Permission denied:
apr_proc_mutex_lock failed. Attempting to shutdown process gracefully.
[Sat Sep 21 22:35:36 2002] [emerg] (13)Permission denied:
apr_proc_mutex_unlock failed. Attempting to shutdown process gracefully.
[Sat Sep 21 22:35:36 2002] [emerg] (13)Permission denied:
apr_proc_mutex_lock failed. Attempting to shutdown process gracefully.
[Sat Sep 21 22:35:36 2002] [emerg] (13)Permission denied:
apr_proc_mutex_unlock failed. Attempting to shutdown process gracefully.
[Sat Sep 21 22:35:37 2002] [notice] child pid 32420 exit signal
Segmentation fault (11)
[Sat Sep 21 22:35:37 2002] [emerg] (13)Permission denied:
apr_proc_mutex_lock failed. Attempting to shutdown process gracefully.
[Sat Sep 21 22:35:37 2002] [emerg] (13)Permission denied:
apr_proc_mutex_unlock failed. Attempting to shutdown process gracefully.
[Sat Sep 21 22:35:37 2002] [emerg] (13)Permission denied:
apr_proc_mutex_lock failed. Attempting to shutdown process gracefully.
[Sat Sep 21 22:35:37 2002] [emerg] (13)Permission denied:
apr_proc_mutex_unlock failed. Attempting to shutdown process gracefully.


And so on, and so on... until I kill httpd entirely.
A friend of mine has the same problem, so I think it is a problem in the
module, isn't it?

I'd be glad to get some help on that issue, since I didn't find a
solution anywhere so far.

--Andy


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message