httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Koen Vingerhoets" <koen.vingerho...@ubench.com>
Subject RE: Piped Logs w/ Win32?
Date Sun, 18 Aug 2002 14:46:47 GMT
Hi,

with the help of this list (thanks Jeff White :) I built a wsh script that
rotates logs.
If you want to, I'll mail it to you :)

Met vriendelijke groet,

Koen Vingerhoets

***** UBench nv *****
http://www.ubench.com
____________________________________________
The information contained in this electronic mail message is privileged and
confidential,
and is intended only for use of the addressee. If you are not the intended
recipient, you
are hereby notified that any disclosure,reproduction, distribution or other
use of this
communication is strictly prohibited.

If you have received this communication in error, please notify the sender
by reply
transmission and delete the message without copying or disclosing it.


-----Original Message-----
From: Jason Soza [mailto:solja@gci.net]
Sent: 17 August 2002 21:22
To: Apache
Subject: Piped Logs w/ Win32?


Hey,

I'm trying to use the 'rotatelogs' program in my virtual hosts so that my
access and error logs won't be getting up to 20mb like they are now. It'd be
cool to have them rotate like they did when I ran Apache on Linux...

Anyway, I followed the manual page concerning piped logs and this is what I
have in my httpd.conf file, in one of my virtual host entries. I was
wondering if there's something special that needs to be done for piped logs
to work in Win32. The time argument is so short because I did this last
night and was hoping for a log rotation to happen by this morning, but no
logging has taken place at all since this entry was added:

CustomLog "|C:/Program Files/Apache Group/Apache/bin/rotatelogs C:/Program
Files/Apache Group/Apachelogs/access_log 40200" common

I've tried surrounding each path in quotes, thinking maybe the spaces were
causing problems, but I got an error on restart saying the log entries take
only one argument. I've tried this as well:

CustomLog "|bin/rotatelogs logs/jdhsgrad_access_log 40200" common

But no go on that either - no errors, but no logging either.

Any help would be great. Thanks!

Jason


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org





---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message