httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jose Correia (J)" <Corr...@telkom.co.za>
Subject [users@httpd] configure - include Module questions
Date Fri, 30 Aug 2002 07:43:20 GMT
Hi all

I have copied a few standard apache .so modules into my libexec and I
have them included in my httpd.conf using the usual:

e.g.

LoadModule setenvif_module    libexec/mod_setenvif.so

ClearModuleList
AddModule mod_setenvif.c

The thing is, it seems I need these to be enabled or included since my
log file is complaining with:

[Thu Aug 29 17:47:45 2002] [error] Cannot remove module
mod_setenvif.c: not found in module list

First question is do I use the --enable-module or the
--activate-module= or  
--add-module or --enabled-shared?

If so, please give example...I got a bit confused when the INSTALL
file said, for example : "Use the --enable-module=NAME and
--disable-module=NAME options to enable
     or disable a particular already distributed module from the
Apache
     src/Configuration.tmpl file. The correct module names (no `mod_'
prefix!)"

Are the talking about a .c or a .so file here? 

Another question is, if I run ./configure again with ONLY this option,
will it overwrite other options that were installed on a previous
./configure??

Thanks a lot
Jose Correia

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message