httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Deaton, Larry" <Larry.Dea...@Surgient.com>
Subject [users@httpd] HTTP Authentication - Domain name
Date Tue, 27 Aug 2002 16:17:26 GMT
Everyone,
	I have been playing around with HTTP Basic authentication using
Apache.  I have this working properly where the user gets prompted for
username and password via the browser.  I need to develop a custom
authentication plugin whereby I can also prompt the user for the Domain
name.  I have noticed this occurring on some sites, especially when
using https://www.myserver.com.   

So, my question is, how does the browser know to just prompt for
username and password versus prompting for username, password, and
domain?  Is this happening because it is purely an HTTPS connection?

I can't find anything in the HTTP specification with regard to the 401
response that talks about this.

Thanks,
Larry Deaton
Surgient Networks



-------------------------------
This e-mail is for the sole use of the intended recipient and may
contain confidential and privileged information. Any unauthorized
review, use or disclosure is strictly prohibited. If you are not the 
intended recipient of this e-mail, please notify sender and delete 
all copies immediately.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message