httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Phydeaux <...@taco.com>
Subject 2.0.40 and Solaris 9 - module "sapi_apache2.c" not compatible...
Date Sat, 10 Aug 2002 12:18:26 GMT
Hi!

I'm trying to install 2.0.40 and I get this when attempting to start the server after
what appears to be a successful configuration, compilation and install:

  httpd: module "sapi_apache2.c" is not compatible with this version of Apache.
  Please contact the vendor for the correct version.

I used the same configure command for this version as I did for 2.0.39. I am running
with shared libraries and I have PHP 4.2.3-dev installed.   The command line used 
for configuration is:

  ./configure --prefix=/www/apache --with-mpm=prefork --enable-mods-shared=all \
  --enable-ssl --with-ssl=/usr/local/ssl --disable-rewrite --disable-auth-anon \
  --disable-auth-digest --enable-so

When compiled, 2.0.40 shows this from apachectl -V

  Server version: Apache/2.0.40
  Server built:   Aug 10 2002 06:54:13
  Server's Module Magic Number: 20020628:0
  Architecture:   32-bit
 Server compiled with....
   -D APACHE_MPM_DIR="server/mpm/prefork"
   -D APR_HAS_SENDFILE
   -D APR_HAS_MMAP
   -D APR_HAVE_IPV6
   -D APR_USE_PROC_PTHREAD_SERIALIZE
   -D APR_USE_PTHREAD_SERIALIZE
   -D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
   -D APR_HAS_OTHER_CHILD
   -D AP_HAVE_RELIABLE_PIPED_LOGS
   -D HTTPD_ROOT="/www/apache"
   -D SUEXEC_BIN="/www/apache/bin/suexec"
   -D DEFAULT_PIDLOG="logs/httpd.pid"
   -D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
   -D DEFAULT_LOCKFILE="logs/accept.lock"
   -D DEFAULT_ERRORLOG="logs/error_log"
   -D AP_TYPES_CONFIG_FILE="conf/mime.types"
   -D SERVER_CONFIG_FILE="conf/httpd.conf"

Does anyone have a clue what is wrong?

reb


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message