httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Boyle Owen" <Owen.Bo...@swx.com>
Subject RE: HTPASSWD
Date Fri, 09 Aug 2002 12:23:40 GMT
There is more to this than meets the eye... See the comments below and post back..

Rgds,

Owen Boyle

>From: Philippe Dhont (Sea-ro) [mailto:Philippe.Dhont@searo.be]
>
>It is still not working. What i exactly try is:
>
>Htpasswd -c /usr/local/netsaint/etc/htpasswd.users netsaintadmin

Why are you using "Htpasswd" (i.e. with capital "H")? Is this just a typo or is your mail
client forcing capitals? I guess it must be, or you'd get "Htpasswd: Command not found"...

Do you have write permissions to a directory under /usr/local? Are you running as root?

Do the intermediate directories already exist? i.e. can you do "ls /usr/local/netsaint/etc"?
Note that htpasswd can only create a file - it cannot build a directory path.

Be aware that your username is too long. Only the first eight characters are significant,
so "netsaintbanana" will also be able to login to this area. This won't make it fail but if
you have a lot of usernames like this you will get unexpected results

>I tried also 
>
>htpasswd -c mypasswords.pwd joe

This should have worked since it has none of the bugs noted above.

>Just for testing if it couldn't be in the path or something 
>and i get the same message:
>Htpasswd: -c and -n options conflict

Have you set up a shell alias for htpasswd, by any chance? Try "alias htpasswd" and see what
it says (I hope it doesn't say "htpasswd -n" :-)

What happens if you say "which htpasswd"?

What happens if you do "htpasswd joe"? or "htpasswd -n joe"?



 

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message