httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sean Correia" <Sean.Corr...@eaw.com>
Subject RE: configuration question
Date Tue, 20 Aug 2002 18:34:08 GMT
Why not put:
'/path/to/apache/bin/apachectl &'
 
in /etc/rc.d/rc.local?
 
Cheers,
Sean

-----Original Message-----
From: cteubner@ncw-av.com [mailto:cteubner@ncw-av.com]
Sent: Tuesday, August 20, 2002 2:28 PM
To: users@httpd.apache.org
Subject: RE: configuration question


Just as an aside - your computer probably won't bother starting Apache the next time you reboot
it.  On RedHat 7.2 you can use chkconfig (in /sbin) to make sure it does but I don't think
apachectl is compatible with it out of the box.  Here's what you do:
1. edit apachectl to be compatible with chkconfig (man chkconfig will tell you how)
2. copy apachectl into /etc/init.d
3. maybe rename apachectl to httpd just to be slick
4. /sbin/chkconfig --level 2345 httpd on
Good luck.
Colin Teubner

-----Original Message-----
From: Dan Stephens [mailto:DanielBStephens@hotmail.com]
Sent: Tuesday, August 20, 2002 2:16 PM
To: users@httpd.apache.org
Subject: Re: configuration question


It worked! 
    I did a cd into /usr/loca/apache2/bin/ and then ran './apachectl start.' After that I
did your 'ps auxww | grep httpd' and low and behold... it works! I then made sure by doing
the netstat line and bang! that too worked. I am not quite sure that exactly the apachectl
file does, however I understand that it now is listening to port 80.
    I then checked my page from a workstation and hit ctrl F5 (my workstations are running
windows) to do more than your standard reftesh and I got the apache webserver page instead
of the "connection refused" page that i was getting. I am still not sure why the apache page
is coming up and not my REAL webpage. Because I know that the the index.html file is in /var/www/html
which is defined as DocumentRoot in the httpd.config file. But oh well this is a big step!
Thanks a lot, you've been such a big help!
  -Dan


Mime
View raw message