httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Andre <an...@hks.com>
Subject Strange Apache problem
Date Wed, 21 Aug 2002 19:11:09 GMT
Hi everyone. This is my first post, go easy on me. 8-)

I'm having a problem with Apache on one of our Linux machines. The
problem appears to lie with displaying a directory listing via nfs. 

First, here are the machines involved.
Machine 1: 
Linux machine running SuSE 7.3
This is the Apache server machine. Note that I removed the SuSE provided
Apache and installed the latest 2.0.40. I've also tried 2.0.39 as well.

Machine 2: 
SGI O2 running IRIX 6.5.12m
This is the machine with the files I'm trying to access via NFS.

In short, I'm accessing the http server on machine 1 and reading files
via NFS on machine 2. Note that I can access the directory, but the file
listing doesn't containg the entire listing of what is in the directory
I'm trying to access. For example, if there are 4 files in the
directory, only 3 are showing up. Note too that accessing the directory
directly on the apache server machine shows the correct amount of files.

Here is what I'm trying to tell you. This is the directory I'm trying to
access:
machine1:/usr/local/apache/htdocs # ls -ld test
lrwxrwxrwx    1 root     root            5 Aug 21 14:06 test -> /mnt2
machine1:/usr/local/apache/htdocs #

/mnt2 is hard-mounted to this machine. Here is the mount entry for
/mnt2: 
machine2:/qa/qa/qa_db on /mnt2 type nfs (rw,addr=1.2.3.4)

Here is a listing of the directory:
machine1:/usr/local/apache/htdocs # ls -l /mnt2
total 20
drwxrwxrwx    6 qa       hks            65 Aug  5 10:49 .
drwxr-xr-x   26 root     root         4096 Aug 21 13:33 ..
drwxr-x---   12 qa       hks          4096 Aug 20 15:25 dir1
drwxr-x---   14 qa       hks          4096 Apr 22 10:20 dir2
drwxr-x---   12 qa       hks          4096 Jul 31 11:04 dir3
drwxr-x---   12 qa       hks          4096 Apr  1 12:06 dir4
machine1:/usr/local/apache/htdocs #

When viewing this page via my web browser:
http://machine1.domain.com/test

It results in only the first 3 directories (dir1, dir2, dir3) to be
listed. 

What's interesting is I can add dir4 in the web browser and it actually
takes me to the directory:
http://machine1.domain.com/test/dir4

Again though, it doesn't grab the complete listing of the files. Looking
on the server machine, this is what should show up in the dir4
directory:
machine1:/usr/local/apache/htdocs/test> ls -l dir4
total 36
drwxr-x---   99 qa       hks          4096 Jul 27 02:11 hp64
drwxr-x---   93 qa       hks          4096 Aug  7 17:35 ibm
drwxr-x---   88 qa       hks          4096 Jul 26 11:03 ibm_aix4
drwxr-x---   72 qa       hks          4096 May  5 19:52 linux32
drwxr-x---   84 qa       hks          4096 Jul 25 13:34 nti
drwxr-x---   86 qa       hks          4096 Jul 26 04:17 origin2000
drwxr-x---   79 qa       hks          4096 May  5 19:53 sgi4000
drwxr-x---  101 qa       hks          4096 Jul 26 11:25 solaris
drwxr-x---    6 qa       hks            76 May  5 19:52 sun32
drwxr-x---   86 qa       hks          4096 Jul 24 09:12 u_alpha
machine1:/usr/local/apache/htdocs/test>

In the web browser though, I see only the following directories:
hp64
ibm
nti
origin2000
u_alpha

I've tried changing the permissions to full permissions. I've also tried
touching the files. Nothing results in the complete file listing to
display. Does anyone have any ideas what is going on? 

Here are some of the settings in the httpd.conf file from machine1:
ServerRoot "/usr/local/apache"
User qa
Group hks
DocumentRoot "/usr/local/apache/htdocs"
<Directory "/usr/local/apache/htdocs">
    Options FollowSymLinks Includes ExecCGI Indexes Multiviews
    XBitHack on
    AllowOverride All
    Order allow,deny
    Allow from all
</Directory>
EnableMMAP off

I can provide you with more httpd.conf settings if need be. Let me know
if they might be of use.

-David

--

David Andre            	
Hibbitt, Karlsson, & Sorensen, Inc.        Phone: 401 727 4200
1080 Main Street                             Fax: 401 727 4208
Pawtucket, RI 02860                        Email: andre@abaqus.com
                                             WWW: www.abaqus.com

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message