httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Turner <kk...@swbell.net>
Subject Re: NAT problem
Date Mon, 08 Jul 2002 07:56:47 GMT
On Mon, 08 Jul 2002 13:59:31 +0800, Gary Lee wrote:

>Hi all,
>
> 
>
>I just setup my linux firewall and use DNAT to translate the public IP
>to the internal web server...I'm using Apache 1.3.15 on windows
>platform....After I finished setting up the firewall and the rules, the
>web server shows that this version of Apache doesn't support that
>scenario..is that true?.....do I have to setup the Virtual Hosts on the
>Apache? And how?...I'm confused with the virtual hosts ip and the web
>server ip..please help!!!!

You don't provide much info.  What app, in whose distribution, using
which kernel?  Not that it would really help me (the gurus will know
what to do with the info), but you might check that you have these rules
at a minimum.  (syntax will depend on your application)
	port rules:
	port 80	forward
	port 443	forward (if you have ssl)

	forwarding rules:
	port 80	<LAN IP or $HOSTNAME>  (use hostname if LAN uses dyn IPs)
	port 443	<LAN IP or $HOSTNAME>

I apologize if I'm stating the obvious, but it's like checking the wall
plug when the lamp doesn't light.  :)
--
gt
It ain't so much what you don't know that gets you in trouble---
it's what you do know that ain't so.--unk

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message