httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Beard <>
Subject Re: install apache 2.0.39 over ontop of red hat apache install
Date Tue, 02 Jul 2002 16:33:45 GMT
On Tue, 2 Jul 2002, Desmond Lee wrote:

> Hi Jeff,
> Thanks for your help.



> I think this is a dumb question, but I couldn't find the answer in the
> apache book that i have so i'm going to ask here: when i go 'rpm -e
> apache-1.3.23'  i get
> error: removing these packages would break dependencies:
>         apache is needed by apacheconf-0.8.2-2
>         webserver   is needed by mod_dav-1.0.3-5
>         webserver is needed by mod_perl-1.26-5
>         webserver is needed by mod_ssl-2.8.7-4
>         webserver is needed by webalizer-2.01_10-1
> How do i remove this dependencies or modules so that i can unistall the old
> version of apache?

Remove those packages first. Or at least that's what I do. I'm not an rpm
wizard. :)


> Thus after removing the old version, i can make sure that the old version is
> gone when i got 'httpd -v' which shoudl show me that version 2 of apache is
> being used. Is that right?

You will need to use the whole path to where apache 2.0 is installed unless
you have added it to your PATH environmental variable.

Without it in PATH:

	/usr/local/apache2/bin/httpd -v

To add it to your PATH (in bash):

	export PATH=$PATH:/usr/local/apache2/bin


	httpd -v


Jeff Beard | Systems Architect, Programmer, Sysadmin
Contact    | jeff at cyberxape dot com
Location   | In front of the computer, Boulder, CO, USA

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message