httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Doug Groves" <gro...@valis.net>
Subject RE: .htaccess on cgi-bin
Date Mon, 08 Jul 2002 19:30:23 GMT
Just another note...

It's still not working.  I've also installed a mail administration program,
which wants to use .htaccess to control usage.  When I try to access that
that CGI, I am not prompted for a password, and the script comes back with
the following...

----
Authentication Failed Username unknown

XXXadmin was unable to determine your username, which
means your webserver is improperly configured to run
with this CGI.  For security reasons, this script
will not run without Apache htaccess lists.
----

The .htaccess file is configured similarly to the one listed below, although
in a different directory.  I've gone through quite a few tutorials and docs
now, and it looks like I have everything running correctly.

I've also tried turning the global AllowOverride on and off in httpd.conf,
with no change of course I restarted the server each time :) .

This has become quite the annoying little bugaboo for me.  I've done it in
the past (a couple of years ago), but now no dice...


-----Original Message-----
From: Doug Groves [mailto:groups@valis.net]
Sent: Monday, July 08, 2002 1:46 PM
To: users@httpd.apache.org
Subject: .htaccess on cgi-bin


Hi,

I'm having problems using .htaccess files to control access into sub-dirs of
the server's cg-bin dir.

Running Apache 1.3.26 under FreeBSD 4.5

In httpd.conf, I've set the following up...

   <Directory "/usr/local/www/cgi-bin/testcgi">
	deny from all
	Options ExecCGI
	AllowOverride AuthConfig
	Order deny, allow
	Allow from xxx.xxx.xxx. (from local IP block only)
   </Directory>

the .htaccess file reads like this...

   AuthType Basic
   AuthUserFile /usr/local/apache/conf/testcgi.passwd
   AuthName TestCGI
   require user admin
   satisfy any

I've also created the testcgi.passwd file, with the user name admin, and the
password.  When I surf to the box from another on the local network, I don't
even get asked for a user name/password and I can gain access to the the
CGIs
within.  This also happens on the local machine.

I'm in the process of building a server to replace the current one, and
haven't
been doing any of this for a couple of years.  Now I'm back at it, and I've
checked docs.  Am I missing something in my conf files that isn't letting
htaccess
to kick in?

Thanks in advance,
Doug



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message