httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "admin" <>
Subject RE: .pl .cgi / cgi-scripts, handlers
Date Tue, 30 Jul 2002 19:47:10 GMT
Look in your httpd.conf file that says:

# If you want to use server side includes, or CGI outside
    # ScriptAliased directories, uncomment the following lines.
    # To use CGI scripts:
    AddHandler cgi-script .cgi .pl

all you do is ADD the other extension as i did.

this is why it's not workng

-----Original Message-----
From: Ken Godee []
Sent: Tuesday, July 30, 2002 3:40 PM
Subject: .pl .cgi / cgi-scripts, handlers

I know this has been talked about alot, but I've combed
thru the email list/faq and have tried many things, but still can't
get it working right. I don't want to make this drawn out, but if
someone has an easy solution it would be great.

Apache 1.3.26 (compiled with modules)
Rh 7.1

I have the "same" 2 scripts with dif. ext's "" and "first.cgi"
On "client" browers first.cgi executes as normal, but wants 
to download instead of executing :(
On the server that Apache is running on, both versions execute 
correctly! (thru browser)  (logged in as root or normal user)

Browsers on both machines are going thru squid proxy.

Permissions (as far as I know) are configured correctly.

[root@cpq866 cgi-bin]# pwd
[root@cpq866 cgi-bin]# l
   -rwxr-xr-x    1 root     root          272 Jul 30 08:35 first.cgi
   -rwxr-xr-x    1 root     root          272 Jul 26 17:23
Tried chowning apache.apache * (no help)

httpd.conf has;

ScriptAlias /cgi-bin/ "/var/www/cgi-bin/"

<Directory "/var/www/cgi-bin">
    AllowOverride None
    AddHandler cgi-script cgi pl
    Options ExecCGI
    Order allow,deny
    Allow from all

 "AddHandler cgi-script cgi pl" inside or outside of 
directive makes no dif. Either does "." as in ".cgi" ".pl"

No errors in error.log

Mod_cgi is compiled into Apache as verified by httpd -l

cgi-bin has no .htaccess file

Only one httpd.conf on system.

I can always just name perl scripts with the ".cgi" instead
of ".pl" to get them to work, but I hate doing things like
Any help would be great.

To unsubscribe, e-mail:
For additional commands, e-mail:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message