httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hayden, Marian" <MHay...@cc.ucc.ie>
Subject Apache 2.0.39 proxy module - getting segmentation fault when cach e is enabled
Date Tue, 30 Jul 2002 10:45:56 GMT
Hi,

I am using Apache 2.0.39 on Redhat 7.3. I have the proxy and cache modules
compiled in. The proxy section works fine until I enable the cache, then I
get the following messages in error_log:
[notice] child pid 5400 exit signal Segmentation fault (11)

I had been using the proxy and caching options in apache 1.3.20 without any
problems. I then upgraded to 1.3.26, but had problems accessing a number of
sites with this (eg www.sciencedirect.com - printing http source). Without
spending too much time on this I installed 2.0.39. This corrected problems
accessing sites but I haven't been able to use the cache.

The cache files are being created.
Httpd.conf details below.

Could anyone help?

Thanks in advance.
Regards,
Marian.


Httpd.conf:
#
# Proxy Server directives. Uncomment the following lines to
# enable the proxy server:
#
<IfModule mod_proxy.c>
ProxyRequests On

<Proxy *>
    Order deny,allow
    Deny from all
    Allow from 143.239.128.88
</Proxy>


</IfModule>
# End of proxy directives.

#cache modules ###
<IfModule mod_cache.c>
 CacheOn On

 <IfModule mod_disk_cache.c> 
  CacheRoot "/usr/local/httpd2/proxy"
  CacheSize 5000
  CacheEnable disk / 
  # CacheDirLevels 5 
  # CacheDirLength 3 
 </IfModule> 

</IfModule> 


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message