httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Trish Hartnett" <trish_...@hotmail.com>
Subject Re: More help with apache and CGI-Perl
Date Mon, 01 Jul 2002 12:41:41 GMT
Hello ,
  thank you for replying. The thing is that I can run the script 
independantly of Apache through MS-DOS and I get:

"E:\Apache\cgi-bin>first.pl
Content-type: text/html

Hello, World.test = 5"

Also I looked in autoexec.bat to see if there was any path information in 
there, but there isn't any path information in there, so I don't know what 
to alter.

Thank you again for your help, can you suggest anything more please ?
Trish.



>From: Arnaldo Pedroso <arnaldopedroso@uol.com.br>
>Reply-To: users@httpd.apache.org
>To: users@httpd.apache.org
>Subject: Re: More help with apache and CGI-Perl
>Date: Mon, 1 Jul 2002 08:54:03 -0300
>
>Hi,
>
>Probally your script doesn't find the perl.exe, take a look if perl.exe is 
>in your path.
>
>
>On Mon, 01 Jul 2002 11:37:19 +0000
>"Trish Hartnett" <trish_bms@hotmail.com> wrote:
>
> >
> >
> > Hello,
> >   I am a newbie and I am trying to use CGI-Perl Perl with Apache 
>(v1.3.26)
> > on Windows 2000.
> >
> > I've looked up all the documentation I could find and I still can't get 
>this
> > thing to work. Every time I try and run a CGI Perl script I keep on 
>getting
> > 500 server error messages.
> >
> > In the error log it says:
> > "[Mon Jul 01 11:46:16 2002] [error] [client 137.43.1.49] (2)No such file 
>or
> > directory: couldn't spawn child process: e:/apache/cgi-bin/test.pl"
> >
> > I've checked and I do have CGI.pm in the C directory, where I installed
> > ActivePerl. (C:\Perl\lib)
> >
> > I've read
> > "http://httpd.apache.org/docs/howto/cgi.html#dynamiccontentwithcgi" 
>because
> > that was suggested last wk on the list when someone had a similar 
>problem.
> >
> > In my httpd.conf the stuff relating to CGI I've got is:
> >
> >   <Directory "E:/Apache/htdocs/manual/">
> >         Options Indexes FollowSymlinks MultiViews ExecCGI Includes
> >         AllowOverride None
> >         Order allow,deny
> >         Allow from all
> >     </Directory>
> >
> >     ScriptAlias /cgi-bin/ "E:/Apache/cgi-bin/"
> >
> > <Directory "E:/Apache/cgi-bin">
> >         AllowOverride All
> >         Options None
> >         Order allow,deny
> >         Allow from all
> >     </Directory>
> >
> > AddHandler cgi-script .cgi
> >
> > And this is the test program I'm trying to run:
> > #!C:/Perl/bin/Perl.exe
> > print "Content-type: text/html\n\n";
> > print "Hello World !";$a=<STDIN>;
> >
> >
> > Any help would be greatly appreciated,
> > Trish.
> >
> >
> > _________________________________________________________________
> > MSN Photos is the easiest way to share and print your photos:
> > http://photos.msn.com/support/worldwide.aspx
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> > For additional commands, e-mail: users-help@httpd.apache.org
> >
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>For additional commands, e-mail: users-help@httpd.apache.org




_________________________________________________________________
MSN Photos is the easiest way to share and print your photos: 
http://photos.msn.com/support/worldwide.aspx


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message