httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ken Godee" <...@perfect-image.com>
Subject .pl .cgi / cgi-scripts, handlers
Date Tue, 30 Jul 2002 19:40:04 GMT
I know this has been talked about alot, but I've combed
thru the email list/faq and have tried many things, but still can't
get it working right. I don't want to make this drawn out, but if
someone has an easy solution it would be great.

Apache 1.3.26 (compiled with modules)
Rh 7.1

I have the "same" 2 scripts with dif. ext's "first.pl" and "first.cgi"
On "client" browers first.cgi executes as normal, but first.pl wants 
to download instead of executing :(
On the server that Apache is running on, both versions execute 
correctly! (thru browser)  (logged in as root or normal user)

Browsers on both machines are going thru squid proxy.

Permissions (as far as I know) are configured correctly.

[root@cpq866 cgi-bin]# pwd
   /var/www/cgi-bin
[root@cpq866 cgi-bin]# l
   -rwxr-xr-x    1 root     root          272 Jul 30 08:35 first.cgi
   -rwxr-xr-x    1 root     root          272 Jul 26 17:23 first.pl
Tried chowning apache.apache * (no help)

httpd.conf has;

ScriptAlias /cgi-bin/ "/var/www/cgi-bin/"

<Directory "/var/www/cgi-bin">
    AllowOverride None
    AddHandler cgi-script cgi pl
    Options ExecCGI
    Order allow,deny
    Allow from all
</Directory>

 "AddHandler cgi-script cgi pl" inside or outside of 
directive makes no dif. Either does "." as in ".cgi" ".pl"

No errors in error.log

Mod_cgi is compiled into Apache as verified by httpd -l

cgi-bin has no .htaccess file

Only one httpd.conf on system.

I can always just name perl scripts with the ".cgi" instead
of ".pl" to get them to work, but I hate doing things like
that.
Any help would be great.
TIA

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message