httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Flash Wilson <fl...@gorge.org>
Subject Re: Cant make 1.3.26 work with .htpasswd
Date Tue, 16 Jul 2002 08:57:46 GMT
n Fri, Jul 12, 2002 at 12:00:24PM +0100, Flash Wilson wrote:
> I upgraded from 1.3.22 to 1.3.26 and since that time have found 
> that .htpasswd is not working. When you put the .htaccess stuff
> in the httpd.conf, it is as if .htpasswd is not being read because
> I get the following error: 
> [Thu Jul 11 08:45:43 2002] [crit] [client 210.96.157.113] configuration error:
> couldn't check user.  No user file?: /registrars/index.html

Hi,

Just to let you all know I have fixed this!

There was an extra mod_auth.so (compiled against the old version
of apache) lurking in libexec. When I removed the LoadModule from
httpd.conf, all worked fine.

Admittedly this was my own stupid fault, so sorry and thanks - 
I still learnt other things on the way to finding a solution ;)

On the other hand the FAQ says:
  Under normal circumstances, the Apache access control modules 
  will pass unrecognized user IDs on to the next access control 
  module in line.

(http://httpd.apache.org/docs/misc/FAQ.html#authauthoritative)

So, not wishing to make excuses but why did my static mod_auth.c
not handle the query correctly even if the DSO was broken?
Maybe something of this type explains why it worked on the test
server but not on the live ones.

Anyway, thanks, and there is the solution in my case.
Flash

-- 
Flash Wilson         flash@gorge.org  	     http://www.gorge.org
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Are you a UK System Administrator?       Join SAGE-WISE for FREE! 
Next London Event: 2002-08-13	         http://www.sage-wise.org

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message