httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rudolf Wolf <rudolf.w...@dantax.cz>
Subject Mod_perl_1.27 + Apache 1.3.26
Date Fri, 12 Jul 2002 12:55:27 GMT
Hi,
I'm newbie in mod_perl. I try to compile mod_perl 1.27 with Apache 1.3.26, I satisfied all
prerequisities, succesfully compiled mod_perl, when I use /usr/local/apache/bin/httpd -l I
can see mod_perl listed in list, but the problem is, that my Apache is not working as before
compiling.
I have Debian 2.2 and Apache has one main (sova.domain.cz) and one virtual host (rt2.domain.cz):


sova:/usr/src/apache_1.3.26# /usr/local/apache/bin/httpd -l
Compiled-in modules:
  http_core.c
  mod_env.c
  mod_log_config.c
  mod_mime.c
  mod_negotiation.c
  mod_status.c
  mod_include.c
  mod_autoindex.c
  mod_dir.c
  mod_cgi.c
  mod_asis.c
  mod_imap.c
  mod_actions.c
  mod_userdir.c
  mod_alias.c
  mod_access.c
  mod_auth.c
  mod_setenvif.c
  mod_perl.c
				      

httpd.conf
-------------
http://web.quick.cz/rudolf.wolf/httpd.conf

Before compiling I can used in my browser both web servers and they sent me responses to my
GET request, BUT after compiling mod_perl, it doesn't work. When I request http://sova.domain.cz/
or http://rt2.domain.cz/, I get only error message in my browser:

Not Acceptable
An appropriate representation of the requested resource / could not be found on this server.
Available variants:
index.html.ca , type text/html, language ca
index.html.cz , type text/html, language cz
index.html.de , type text/html, language de
index.html.dk , type text/html, language da
index.html.ee , type text/html, language et
index.html.el , type text/html, language el ..............

Only one resource is working and it's manual nothing else. When I checked access logs of web
servers, there is no log records as I don't request any pages, but before compiling, it was
working too. Of course, there is no error log records in error log.

My compile command line was:
perl Makefile.PL APACHE_SRC=/usr/src/apache_1.3.26/src DO_HTTPD=1 USE_APACI=1 EVERYTHING=1

make
make test (everything OK)
make install

/etc/init.d/apachectl stop
/etc/init.d/apachectl start


Can you help me?

Thanks,
Ruda.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message