httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael J Humphries" <admin...@alphacomm.net>
Subject RE: problems upgrading from 1.3.19 to 1.3.26
Date Thu, 18 Jul 2002 15:40:09 GMT
I hope that this helps after I got to this point I checked a couple of
URL's we host and they seem to work the log says 1.3.26 but the httpd -v
says 1.3.19 I know this may be elementary but I am confused as to why
this is can you please help :-?

Last login: Wed Jul 17 14:15:03 2002 from 198.69.163.13
[root@saturn /root]# cd /etc/rc.d/init.d
[root@saturn init.d]# ./httpd stop
Stopping httpd:                                            [  OK  ]
[root@saturn init.d]# ./httpd status
httpd is stopped
[root@saturn init.d]# cd /etc/httpd/conf
[root@saturn conf]# ls
Makefile                 httpd.conf          httpd.conf.old
magic.default         srm.conf.default  ssl.prm
access.backup_7.10.2002  httpd.conf.1.3.22   httpd.conf.old2
mime.types            ssl.crl
access.conf              httpd.conf.1.3.26   httpd.conf.rpmchng
mime.types.default    ssl.crt
access.conf.default      httpd.conf.backup   httpd.conf.rpmsave
srm.backup_7.10.2002  ssl.csr
httpd.backup_7.10.2002   httpd.conf.default  magic
srm.conf              ssl.key
[root@saturn conf]# cp httpd.conf.1.3.26 httpd.conf
cp: overwrite `httpd.conf'? y
[root@saturn conf]# cd ../bin
[root@saturn bin]# ./apachectl start
./apachectl start: httpd started
[root@saturn bin]# cd ../logs
[root@saturn logs]# ls
access_log    error_log.2            error_log.midnightsoftworks
saturn.midnightsoftworks.com-access_log
access_log.1  error_log.3            error_log.norwayspeedway
saturn.midnightsoftworks.com-error_log
access_log.2  error_log.4            error_log.reboxpaper
ssl_request_log
access_log.3  error_log.alphacomm    error_log.riversideseamlessgutters
ssl_request_log.1
access_log.4  error_log.belgiumtown  error_log.santosalodge
ssl_request_log.2
error_log     error_log.clubtivoli   error_log.stephensonag
ssl_request_log.3
error_log.1   error_log.deyoungzoo   error_log.tnt-photography
ssl_request_log.4
[root@saturn logs]# tail error_log  
[Wed Jul 17 16:18:11 2002] [notice] Accept mutex: sysvsem (Default:
sysvsem)
[Wed Jul 17 16:18:27 2002] [crit] (98)Address already in use: make_sock:
could not bind to port 443
[Wed Jul 17 16:19:32 2002] [notice] caught SIGTERM, shutting down
[Wed Jul 17 16:20:07 2002] [notice] Apache/1.3.19 (Unix)
(Red-Hat/Linux) PHP/4.0.1pl2 mod_perl/1.24 configured -- resuming normal
operations
[Wed Jul 17 16:20:07 2002] [notice] suEXEC mechanism enabled (wrapper:
/usr/sbin/suexec)
[Thu Jul 18 05:58:47 2002] [error] [client 169.207.138.221] Client sent
malformed Host header
[Thu Jul 18 09:35:08 2002] [error] [client 210.179.129.11] Client sent
malformed Host header
[Thu Jul 18 10:21:10 2002] [notice] caught SIGTERM, shutting down
[Thu Jul 18 10:22:13 2002] [notice] Apache/1.3.26 (Unix) configured --
resuming normal operations
[Thu Jul 18 10:22:13 2002] [notice] Accept mutex: sysvsem (Default:
sysvsem)
[root@saturn logs]# httpd -v
Server version: Apache/1.3.19 (Unix)  (Red-Hat/Linux)
Server built:   Mar 29 2001 12:52:37
[root@saturn logs]# 
[root@saturn logs]#

Michael Humphries
Alphacomm.net
Network Administrator
906-639-3500
877-450-3500
adminmjh@alphacomm.net
www.alphacomm.net 


-----Original Message-----
From: Lewis Watson [mailto:lists@visionsix.com] 
Sent: Wednesday, July 17, 2002 4:22 PM
To: users@httpd.apache.org
Subject: Re: problems upgrading from 1.3.19 to 1.3.26

What does the error log show? Also, verify that the old apache is not
running.
Lewis Watson

----- Original Message -----
From: "Michael J Humphries" <adminmjh@alphacomm.net>
To: <users@httpd.apache.org>
Sent: Wednesday, July 17, 2002 4:23 PM
Subject: RE: problems upgrading from 1.3.19 to 1.3.26


>
> This is what happens when I try that
> [root@saturn bin]# ./apachectl start
> ./apachectl start: httpd started
> [root@saturn bin]# ./apachectl stop
> ./apachectl stop: httpd (no pid file) not running
>
> Michael Humphries
> Alphacomm.net
> Network Administrator
> 906-639-3500
> 877-450-3500
> adminmjh@alphacomm.net
> www.alphacomm.net
>
>
> -----Original Message-----
> From: Lewis Watson [mailto:lists@visionsix.com]
> Sent: Wednesday, July 17, 2002 4:13 PM
> To: users@httpd.apache.org
> Subject: Re: problems upgrading from 1.3.19 to 1.3.26
>
> yup... Go into that directory. Got apachectl there?
> If so type ./apachectl start
>
> Lewis Watson
>
> ----- Original Message -----
> From: "Michael J Humphries" <adminmjh@alphacomm.net>
> To: <users@httpd.apache.org>
> Sent: Wednesday, July 17, 2002 4:06 PM
> Subject: RE: problems upgrading from 1.3.19 to 1.3.26
>
>
> > There is no /etc/httpd/sbin/ folder only .../bin/
> >
> > Michael Humphries
> > Alphacomm.net
> > Network Administrator
> > 906-639-3500
> > 877-450-3500
> > adminmjh@alphacomm.net
> > www.alphacomm.net
> >
> >
> > -----Original Message-----
> > From: Lewis Watson [mailto:lists@visionsix.com]
> > Sent: Wednesday, July 17, 2002 3:57 PM
> > To: users@httpd.apache.org
> > Subject: Re: problems upgrading from 1.3.19 to 1.3.26
> >
> > Go into /etc/httpd and see if you have sbin/apachectl in there. Make
> > sure
> > your old version is not running and and do ./apachectl start...
> > Lewis Watson
> >
> > ----- Original Message -----
> > From: "Michael J Humphries" <adminmjh@alphacomm.net>
> > To: <users@httpd.apache.org>
> > Sent: Wednesday, July 17, 2002 3:13 PM
> > Subject: RE: problems upgrading from 1.3.19 to 1.3.26
> >
> >
> > > My .19 install is in /etc/httpd/
> > > When I ran ./configured I gave it the prefix=/etc/httpd/
> > > --enable-module=...
> > > Does that help if not I will give you any info needed
> > >
> > > Michael Humphries
> > > Alphacomm.net
> > > Network Administrator
> > > 906-639-3500
> > > 877-450-3500
> > > adminmjh@alphacomm.net
> > > www.alphacomm.net
> > >
> > >
> > > -----Original Message-----
> > > From: Lewis Watson [mailto:lists@visionsix.com]
> > > Sent: Wednesday, July 17, 2002 2:52 PM
> > > To: users@httpd.apache.org
> > > Subject: Re: problems upgrading from 1.3.19 to 1.3.26
> > >
> > >
> > > ----- Original Message -----
> > > From: "Michael J Humphries" <adminmjh@alphacomm.net>
> > > To: <users@httpd.apache.org>
> > > Sent: Wednesday, July 17, 2002 2:34 PM
> > > Subject: RE: problems upgrading from 1.3.19 to 1.3.26
> > >
> > >
> > > > I have installed apache 1.3.26 instead of 1.3.22 and everything
> > seemed
> > > > to work I got though the ./apachectl start and all was good it
> said
> > it
> > > > started but then I ran httpd -v and it shows 1.3.19 so I stopped
> > > 1.3.19
> > > > rebooted the server and checked the httpd -v it said 1.3.19 so I
> > > stopped
> > > > the httpd from /et/rc.d/init.d and tried to run ./apachectl
start
> it
> > > > says it starts but then I run ./apachectl stop and it says no
pid
> > > httpd
> > > > not running
> > > > Any ideas would be more than welcome.
> > > >
> > > > Michael Humphries
> > > > Alphacomm.net
> > > > Network Administrator
> > > > 906-639-3500
> > > > 877-450-3500
> > > > adminmjh@alphacomm.net
> > > > www.alphacomm.net
> > > >
> > >
> > > Where is your .22 apache installed and where in the file system is
> > > apache
> > > .26 installed? What ./config did you use? This can help to see
what
> is
> > > happening.
> > > Thanks.
> > > Lewis Watson
> > >
> > >
> > >
> > >
> > >
> ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> > > For additional commands, e-mail: users-help@httpd.apache.org
> > >
> > >
> > >
> > >
> ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> > > For additional commands, e-mail: users-help@httpd.apache.org
> > >
> >
> >
> >
---------------------------------------------------------------------
> > To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> > For additional commands, e-mail: users-help@httpd.apache.org
> >
> >
> >
> >
---------------------------------------------------------------------
> > To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> > For additional commands, e-mail: users-help@httpd.apache.org
> >
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message