httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jroland <jrol...@roland.net>
Subject Re: USR1 & HUP problem
Date Mon, 24 Jun 2002 19:43:29 GMT
Okay.  I've just updated to 1.3.26 latest stable from the apache website 
and the same thing happens (apache goes on "pause" when sending a HUP, 
USR1, or a graceful/restart).  Does anyone know how to fix this?  It's on 
a series of production webservers.

TIA,
Jim


On Sun, 23 Jun 2002, Jim Roland wrote:

> I just recently compiled (and patched for the chunk problem recently) 1.3.22
> and suddenly find myself having problems with my log rotation process.
> 
> I have logs being rotated with a "killall -USR1 httpd" after the rotation is
> done.  This worked fine until I went from 1.3.20 to 1.3.22.  Now the httpd
> server does not do a graceful restart, but it "sleeps".  All httpd processes
> show running, netstat shows they have sockets running, but it does not
> respond to requests or it refuses connection on port 80 as if httpd is not
> running at all.  This "sleeping" occurs with sending a -HUP, -USR1, and even
> with a "apachectl restart" or "apachectl graceful".
> 
> The only way to get Apache to start serving requests again is a full-on
> "apachectl stop ; apachectl start".
> 
> Anyone have any ideas?  There are no errors in the error log that prove
> useful.  System is running RedHat 7.2 with latest patches.  This start
> occuring when installed the apache 1.3.22 vulnerability RPM, which prompted
> me to roll my own.  Same problem occurs in my own as well.
> 
> Thanks,
> Jim Roland, RHCE
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message