httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rasmus Lerdorf <ras...@apache.org>
Subject Re: PHP 4.2 & Apache 2
Date Mon, 24 Jun 2002 16:15:50 GMT
You need to 'make install' in your Apache source directory to actually
install Apache and the apxs binary.

On Mon, 24 Jun 2002, Scott Taylor wrote:

> I have configured Apache 2 to /usr/local/apache2 (but not used MAKE or MAKE
> INSTALL yet) as I am configuring PHP, MySQL etc...I am using instructions
> from a PHP and MySQL book (which I successfully used before).
>
> I am in the PHP directory trying to configure these things. I have tried to
> use this command:
>
> [root@localhost php-4.2.1]# ./configure --with-mysql=/opt/mysql --with-xml
> --with-apxs2=/usr/local/apache2/bin/apxs --with-curl=/root/curl-7.9.3/
> --with-pspell=/root/pspell-.12.2/ --enable-shared-pdflib --enable-track-vars
>
> But I am getting the following (as there does not appear to be a
> apache2/bin/apxs...because I haven't used MAKE or MAKE INSTALL?)
>
> Configuring SAPI modules
> checking for AOLserver support... no
> checking for Apache 1.x module support via DSO through APXS... no
> checking for Apache 1.x module support... no
> checking for mod_charset compatibility option... no
> checking for Apache 2.0 module support via DSO through APXS...
>
> Sorry, I cannot run apxs.  Possible reasons follow:
>
> 1. Perl is not installed
> 2. apxs was not found. Try to pass the path using --with-apxs2=/path/to/apxs
> 3. Apache was not built using --enable-so (the apxs usage page is displayed)
>
> The output of /usr/local/apache2/bin/apxs follows:
> ./configure: /usr/local/apache2/bin/apxs: No such file or directory
> configure: error: Aborting
>
> Any ideas...should I be using /root/httpd-2.0.39 the path to the source?
> Should the missing files not be in the Apache 2 pack?
>
> Regards
>
> Scott
>
> On Monday 24 June 2002 4:48 pm, Guillaume Tournat wrote:
> > To compile PHP 4 with Apache 2, you need to use
> > the option '--with-apxs2=/to/dir/of/httpd2/bin/apxs'
> > instead of the classical '--with-apache' which is for
> > Apache 1.3.x
> >
> > Guillaume
> >
> > ----- Original Message -----
> > From: "Scott Taylor" <scott.taylor@4i-dotcom.com>
> > To: <users@httpd.apache.org>
> > Sent: Monday, June 24, 2002 5:42 PM
> > Subject: PHP 4.2 & Apache 2
> >
> > > Can I assume that the below error is correct and that Apache 2 really
> >
> > doesn't
> >
> > > work with PHP 4.2.
> > >
> > > This stopped mid way through ./configure...
> > >
> > > Configuring SAPI modules
> > > checking for AOLserver support... no
> > > checking for Apache 1.x module support via DSO through APXS... no
> > > checking for Apache 1.x module support... configure: error: --with-apache
> >
> > does
> >
> > > not work with Apache 2.x!
> > >
> > > Regards
> > >
> > > Scott
> > >
> > > ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> > > For additional commands, e-mail: users-help@httpd.apache.org
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> > For additional commands, e-mail: users-help@httpd.apache.org
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message