httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ping Xiao <px...@proteus.dis.mq.edu.au>
Subject HELP - apache 2 hangs after few hours
Date Mon, 24 Jun 2002 06:10:42 GMT
Dear All,

Help please and thanks in advance.

My problem
==========
Apache 2 hangs after hours (ranging from 4 hours to 67 hours) of running. 
When this happens, people can't access the site, for example, it takes
forever trying to get a page but can't get anything. 

Also when this happens, there are still many process running.


My platform
===============
Solaris 2.6 last patched in April
75 virtual hosts
Apache 2.0.39
configuration:

./configure --prefix=/usr/local/httpd-2.0.39 --enable-modules="auth_anonauth_db
m auth_ldap charset_lite dav expires ext_filter info mime_magic setenv_if 
speling usertrack vhost_alias file_cache cache ldap"

Error logs
==========
/var/adm/messages didn't log anything
/usr/local/httpd-2.0.39/log/error_log logged following in the case of the
most recent hang:

[Mon Jun 24 12:37:27 2002] [notice] Graceful restart requested, doing
restart
[Mon Jun 24 12:37:28 2002] [notice] Apache/2.0.39 (Unix) DAV/2 configured
-- resuming normal operations
[Mon Jun 24 12:39:54 2002] [error] [client 80.137.75.21] File does not
exist: /hosts/mq/htdocs/klicks, referer: http://www.svl-skat.de/start.htm
[Mon Jun 24 14:01:14 2002] [notice] SIGHUP received.  Attempting to
restart
[Mon Jun 24 14:01:15 2002] [notice] Apache/2.0.39 (Unix) DAV/2 configured
-- resuming normal operations
[Mon Jun 24 14:02:12 2002] [warn] child process 3365 still did not exit,
sending a SIGTERM
[Mon Jun 24 14:02:12 2002] [warn] child process 3367 still did not exit,
sending a SIGTERM
[Mon Jun 24 14:02:12 2002] [warn] child process 3369 still did not exit,
sending a SIGTERM
[Mon Jun 24 14:02:12 2002] [notice] caught SIGTERM, shutting down
[Mon Jun 24 14:02:23 2002] [notice] Apache/2.0.39 (Unix) DAV/2 configured
-- resuming normal operations

Other information
=================
I have another machine running the same version but doesn't have the
problem. The difference between is:

1. there are 70+ virtual hosts on the machine which has the problem but
   there are only web site on the other machine.

2. I have to increase the number of file descriptor by issuing
   "ulimit -n 256" before I start the apache 2 on the machine that has the
   problem.

On the problem machine, 
1. I normally have 20 - 65 httpd processes running
2. Command "top" normally showes the following summary when it is working:

last pid:  9664;  load averages:  0.40,  0.31,  0.29 15:19:34
144 processes: 142 sleeping, 1 zombie, 1 on cpu
CPU states: 89.1% idle,  1.7% user,  7.7% kernel,  1.6% iowait,  0.0% swap
Memory: 640M real, 14M free, 106M swap in use, 396M swap free

3. It doesn't seem to have a disk space problem.


Regards,
Ping

-----------------------------------------------------------------
Ping XIAO
Internet Information Projects and Services (IIPS)
Macquarie University, North Ryde, NSW 2109, AUSTRALIA

E-mail: Ping.Xiao@mq.edu.au  URL: http://www.ois.mq.edu.au/staff/pxiao
Phone:  +61 (0)2 9850 6515
------------------------------------------------------------------



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message