httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lad.G...@cle.philips.com
Subject Re: MS Word, .htaccess & Passwords
Date Tue, 04 Jun 2002 15:56:34 GMT

You DA MAN!!!!! Thanks. What I had to do in the httpd.conf file is to
configure the directives in the following manner:

<Files ~ "^\.ht">
    Order allow,deny
    Deny from all
</Files>
<files _vti_inf.html>
   Allow from all
   Satisfy Any
   </files>
<files _vti_bin>
Allow from all
Satisfy any
</files>

I changed the Allowoverride in <Directory "/usr/local/httpd/html"> (document root) to
Allowoverride AuthConfig Limit   from Allowoverride AuthConfig. This solved the problem with
the server error after .htaccess file was changed.
Should I also do this to <Directory /> Just above the <Directory "/usr/local/httpd/html">
directives?


One last problem that I found. In the protected area I also have word docs, and trying to
open them I get asked for the password. The access log
shows:
123.54.232.18 - lgaal [04/Jun/2002:11:59:27 -0400] "GET /Mx8000/doc/Mx8k_bug.doc HTTP/1.1"
304 -
123.54.232.18 - - [04/Jun/2002:11:59:29 -0400] "OPTIONS /Mx8000/doc HTTP/1.1" 401 409
123.54.232.18 - - [04/Jun/2002:11:59:29 -0400] "OPTIONS /Mx8000/doc/Mx8k_bug.doc HTTP/1.1"
401 409
123.54.232.18 - lgaal [04/Jun/2002:11:59:57 -0400] "OPTIONS /Mx8000/doc/Mx8k_bug.doc HTTP/1.1"
200 -
123.54.232.18 - - [04/Jun/2002:11:59:57 -0400] "GET /_vti_inf.html HTTP/1.1" 404 219
123.54.232.18 - - [04/Jun/2002:11:59:57 -0400] "POST /_vti_bin/shtml.exe/_vti_rpc HTTP/1.1"
404 233
123.54.232.18 - lgaal [04/Jun/2002:11:59:57 -0400] "OPTIONS /Mx8000/doc/Mx8k_bug.doc HTTP/1.1"
200 -
123.54.232.18 - lgaal [04/Jun/2002:11:59:57 -0400] "GET /Mx8000/doc/Mx8k_bug.doc HTTP/1.1"
304 -

Line 4 shows that I had to enter the username, etc again. Any ideas on that one?

Regards,
Lad.






Joshua Slive <joshua@slive.ca> on 06/04/2002 09:42:44 AM

Please respond to users@httpd.apache.org

To:   users@httpd.apache.org
cc:

Subject:  Re: MS Word, .htaccess & Passwords


Lad.Gaal@cle.philips.com wrote:
> First off, I want to thank you for taking the time to answer my
questions.
> I thought I was pretty good at figuring stuff out until this MS curse.
>
> After I modify the .htaccess file with the file exclusion directive, the
> error log states:
> [Tue Jun  4 07:24:59 2002] [alert] [client 123.54.232.18]
/usr/local/httpd/html/.htaccess: allow not allowed here
> [Tue Jun  4 07:24:59 2002] [alert] [client 123.54.232.18]
/usr/local/httpd/html/.htaccess: allow not allowed here

That means the AllowOverride directive in httpd.conf is not set
correctly.  You need at least "AllowOverride AuthConfig Limit"

>
> Which is the same is I change from Basic authentication to Digest, that's
another story.....
>
> Alias did not have an effect. I placed this line immediately after the
alias statement for /icons/
> Alias /home/trip/_vti_inf.html "/usr/local/httpd/html/_vti_inf.html"
#per the script the syntax should be Alias fakename realname

Alias takes URL-paths, not file-paths, so it should be more like
Alias /_vti_inf.html /usr/local/httpd/html/_vti_inf.html


> I then tried to add another files directive underneath the above, as
such:
> <files _vti_bin/shtml.exe/_vti_rpc>
> Allow from all
> Satisfy any
> </files>
>
> The results are same as above in the logs. No further progress.

<files> only takes filenames, not full paths.  You can try
<files _vti_rpc>, or <files _vti_bin>, but I'm not sure if it will work
or not.  You may need to create the _vti_bin directory and then use
<files shtml.exe>

JOshua.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org








---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message