httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Haugan Toldnes <chris...@tihlde.org>
Subject Problem compiling apache-2.0.36 (libtool, link run-path-error.)
Date Wed, 12 Jun 2002 16:53:58 GMT

I'm trying to compile apache-2.0.36 on linux/i586.

The compilation exits with the following error:

<cut>

 make[3]: Entering directory `/usr/src/trustix/BUILD/httpd-2.0.36/srclib/apr'
/bin/sh /usr/src/trustix/BUILD/httpd-2.0.36/srclib/apr/libtool --silent --mode=link gcc -g
-O2 -pthread -DHAVE_CONFIG_H -DLINUX=2 -D_REENTRANT -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -D_SVID_SOURCE
-I./include -I../include -o libapr.la -rpath refix/lib strings/apr_cpystrn.lo strings/apr_fnmatch.lo
strings/apr_snprintf.lo strings/apr_strings.lo strings/apr_strnatcmp.lo strings/apr_strtok.lo
passwd/apr_getpass.lo passwd/apr_md5.lo tables/apr_hash.lo tables/apr_tables.lo file_io/unix/copy.lo
file_io/unix/dir.lo file_io/unix/fileacc.lo file_io/unix/filedup.lo file_io/unix/filepath.lo
file_io/unix/filestat.lo file_io/unix/flock.lo file_io/unix/fullrw.lo file_io/unix/mktemp.lo
file_io/unix/open.lo file_io/unix/pipe.lo file_io/unix/readwrite.lo file_io/unix/seek.lo network_io/unix/inet_ntop.lo
network_io/unix/inet_pton.lo network_io/unix/poll.lo network_io/unix/sendrecv.lo network_io/unix/sockaddr.lo
network_io/unix/sockets.lo network_io/unix/sockopt.lo threadproc/unix/proc.lo threadproc/unix/procsup.lo
threadproc/unix/signals.lo threadproc/unix/thread.lo threadproc/unix/threadpriv.lo misc/unix/errorcodes.lo
misc/unix/getopt.lo misc/unix/getuuid.lo misc/unix/otherchild.lo misc/unix/rand.lo misc/unix/start.lo
misc/unix/uuid.lo misc/unix/version.lo locks/unix/global_mutex.lo locks/unix/proc_mutex.lo
locks/unix/thread_cond.lo locks/unix/thread_mutex.lo locks/unix/thread_rwlock.lo time/unix/time.lo
time/unix/timestr.lo mmap/unix/common.lo mmap/unix/mmap.lo shmem/unix/shm.lo i18n/unix/xlate.lo
user/unix/groupinfo.lo user/unix/userinfo.lo memory/unix/apr_pools.lo atomic/unix/apr_atomic.lo
dso/unix/dso.lo
libtool: link: only absolute run-paths are allowed
make[3]: *** [libapr.la] Error 1
make[3]: Leaving directory `/usr/src/trustix/BUILD/httpd-2.0.36/srclib/apr'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/src/trustix/BUILD/httpd-2.0.36/srclib/apr'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/trustix/BUILD/httpd-2.0.36/srclib'
make: *** [all-recursive] Error 1

</cut>

I searched and got a tip using 'buildconf' in the httpd-2.0.36 directory,
but that didn't seem to change anything.

This is my configuration:

<cut>

./configure \
        --enable-modules=all \
        --enable-mods-shared=all \
        --enable-suexec \
        --with-suexec-docroot=/home/httpd/html \
        --with-suexec-caller=nobody \
        --enable-ssl

</cut>


Have anyone been in this jam before? Any advice is very welcome.


Thanks in advance


chr


-- 
Christian H. Toldnes

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message