httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Barrie Robinson <barrie.robin...@emotus.com>
Subject Name Virtual Hosts OSX
Date Fri, 21 Jun 2002 19:45:05 GMT
I seem to be having a problem setting up name NameVirtualHosts. I have 
two hard drives on OSX. My startup and a partitioned drive. My site for 
(access.emotus.com) is on a partition called 'files' the path is 
'Volumes/files/Sites/accessemotus/'. The domain 'emotus.com' is hosted 
externally and 'access.emotus.com' points to my fixed IP address (the 
OSX server that I've set up). If I enter 'access.emotus.com' as the url 
in my browser I get the default apache html. I also get this if I enter 
'127.0.0.1'.

I am new to apache so am probably doing something very simple wrong. 
Could somebody possibly give me some advice? I've included some of the 
httpd.conf set-up below.

Thanks in anticipation,

Barrie

----

I've set the server to...

----
# You will have to access it by its address anyway, and this will make
# redirections work in a sensible way.
#

ServerName emotus.com:80


#
# UseCanonicalName: Determines how Apache constructs self-referencing
# URLs and the SERVER_N
----

and further down in the httpd.conf file :

----
NameVirtualHost *

<VirtualHost *>
DocumentRoot /Volumes/files/Sites/accessemotus
ServerName access.emotus.com
</VirtualHost>
----

however I get this message on server start:

----

[alert] httpd: Could not determine the server's fully qualified domain 
name, using 127.0.0.1 for ServerName
/usr/sbin/apachectl start: httpd started


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message