httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jon Gethner <geth...@analyze.com>
Subject Proxy configuration for 2.0.36 Solaris ?
Date Sat, 22 Jun 2002 14:02:04 GMT
First time I have tried version 2.0.xx apache.

Proxy handling does not seem to work. 1. using the http proxy on port 80 
from my local net through my httpd server does not pass the requests. 2. An 
external request that tried to proxy through my httpd does not generate a 
rejected message in error_log (like it did in 1.3.20). Local requests 
actually return the httpd root directory index.html page, instead of giving 
a error page.

build was ./configure --enable-module=proxy

config file contains...

<IfModule mod_proxy.c>
ProxyRequests  On

<Proxy *>
     Order deny,allow
     Deny from all
     Allow from 154.246.4
</Proxy>

My local network is the 154.246.4.xxx network.
The outside internet is a 216.xxx network.
The system running httpd is dual homed for the two network cards.

This setup worked fine in 1.3.20. The same proxy section commands were used 
in 1.3.20, though of course they are in a main section here.

So, I think I must be missing some other essential conf file settings, or 
must run configure with other options.

Pointers would be appreciated. Since I haven't seen any message threads on 
this, and it is so basic, it seems that I must be missing something entire 
obvious.

Thanks,

Jon Gethner
Adaptive Analyzer Technologies
New York, NY 10038
www.analyze.com 


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message