httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From c..@eircom.net
Subject Re: Can't get Apache running with name-based vhosts
Date Tue, 18 Jun 2002 21:10:11 GMT
OK I tried that and this what I'm getting:

[root@leviathan /root]# httpd -t
Syntax OK
[root@leviathan /root]# httpd -S
VirtualHost configuration:
wildcard NameVirtualHosts and _default_ servers:
*:*                    is a NameVirtualHost
                        default server irelands-web.ie 
(/etc/httpd/conf/httpd.conf:1051)
                        port * namevhost irelands-web.ie 
(/etc/httpd/conf/httpd.conf:1051)
                        port * namevhost harmonairconditioning.ie 
(/etc/httpd/conf/httpd.conf:1065)
[root@leviathan /root]# /etc/rc.d/init.d/httpd restart
Stopping httpd:                                            [FAILED]
Starting httpd:                                            [FAILED]

Just to make sure:
<VirtualHost *>
     ServerAdmin root@irelands-web.ie
     DocumentRoot /var/www/html
     ServerName irelands-web.ie
     ServerAlias irelands-web.ie *.irelands-web.ie
     ErrorLog /var/log/http/error_log
         <Location />
         AllowOverride none
         Options Indexes
         Order allow,deny
         Allow from all
         </Location>
</VirtualHost>

<VirtualHost *>
         ServerAdmin root@irelands-web.ie
         ServerName harmonairconditioning.ie
         ServerAlias harmonairconditioning.ie *.harmonairconditioning.ie
         DocumentRoot /home/harmonaircon/www
         ErrorLog /var/log/httpd/access.log
         TransferLog /var/log/transferlog
         <Location />
         AllowOverride none
         Options Indexes
         Order allow,deny
         Allow from all
         </Location>
</VirtualHost>

What do you have for "Listen" "BindAddress" and "Port"?
Thanks for the help so far BTW

Chris
At 16:30 18/06/02 -0400, Brian T Glenn wrote:
>On Tue, 18 Jun 2002 cnb@eircom.net wrote:
>
> > Running RH 7.1 with Apache-1.3.19-5
>
>You should also definitely consider upgrading to the latest stable 1.3
>version.
>
>If the config below doesn't work for you, send back the output of httpd -t
>
>This is how I define my vhosts and have never had a problem:
>
>NameVirtualHost *
>
><VirtualHost *>
>      ServerAdmin root@irelands-web.ie
>      DocumentRoot /var/www/html
>      ServerName irelands-web.ie
>      ServerAlias irelands-web.ie *.irelands-web.ie
>      ErrorLog /var/log/http/error_log
>      <Location />
>           AllowOverride none
>           Options Indexes
>           Order allow,deny
>           Allow from all
>      </Location>
></VirtualHost>
>
><VirtualHost 194.125.22.1>
>      ServerAdmin root@irelands-web.ie
>      ServerName harmonairconditioning.ie
>      ServerAlias harmonairconditioning.ie *.harmonairconditioning.ie
>      DocumentRoot /home/harmonaircon/www
>      ErrorLog /var/log/httpd/access.log
>      TransferLog /var/log/transferlog
>      <Location />
>           AllowOverride none
>           Options Indexes
>           Order allow,deny
>           Allow from all
>      </Location>
></VirtualHost>
>
># this isn't necessary
>#<VirtualHost _default_:*>
>#</VirtualHost>
>
>
>--
>Brian T Glenn
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>For additional commands, e-mail: users-help@httpd.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message