httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andy Ozment <andy.ozm...@cc.gatech.edu>
Subject Configuring/Compiling apache 1.3.26 with mod_ssl 2.8.9-1.3.26 on SGI Irix 6.5.14 system - cannot find ssl libraries located in lib32, even with BUILD_SSL
Date Fri, 21 Jun 2002 22:07:08 GMT
Hello,

I'm trying to configure/compile apache 1.3.26 with mod_ssl 2.8.9-1.3.26
on SGI Irix 6.5.14 n32 mips3 system. When I try to use the auto-conf
like tool provided by apache, it cannot successfully locate my openssl
library files, which are located in /usr/freeware/lib32.

The configuration tool only looks in the various /lib directories
(/usr/lib, /usr/local/lib, etc). Using BUILD_SSL I am directing it to
the correct root directory of /usr/freeware, but it still only searches
in /usr/freeware/lib.

Because BUILD_SSL didn't work, I tried using these environmental
variables:
PATH=${PATH}:/usr/freeware/bin \
LDFLAGS="-n32 -L/usr/freeware/lib32 -R/usr/freeware/lib32" \
CFLAGS="-I/usr/freeware/include -mips3 -n32" \
./configure <etc>

Unfortunately, I still get an error message:
Error: Cannot find SSL library files in any of the following dirs:
Error: . /lib /usr/lib /usr/local/lib
      + SSL library path: [SYSTEM]

I've also tried playing with the following flags, to no avail:
CFLAGS_SHLIB, LD_SHLIB, LDFLAGS_SHLIB, LDFLAGS_SHLIB_EXPORT.

To ensure that I correctly identified the problem, I temporarily moved
my /usr/freeware/lib32 to /usr/freeware/lib. That did, indeed, fix the
problem. Unfortunately, this workaround won't work permanently in our
environment.

I would greatly appreciate any tips on how to proceed with identifying a
solution. (I have Googled, searched the newsgroups, and this mailing
list's archives. I also searched the mod_ssl list archives, but I
believe that this is a more appropriate forum. I apologize if I'm
incorrect in that belief).

I assume that I am failing to identify the correct flag or environmental
variable to pass to the configuration tool, but despite searching the
src/Configuration.* files, I am still at a loss.

I am including the complete configuration command I'm running below.

Thanks!
Andy


SSL_BASE=/usr/freeware \
CC=/usr/local/bin/gcc-2.95.2 \
./configure \
--prefix=/usr/etc/httpd \
--enable-module=ssl \
--enable-shared=ssl \
--enable-rule=SSL_SDBM \
--enable-rule=SSL_EXPERIMENTAL \
--enable-rule=SSL_VENDOR \
--disable-rule=SSL_COMPAT \
--enable-module=so \
--enable-module=info \
--enable-module=rewrite \
--enable-rule=SHARED_CORE


-- 
  Andy Ozment
  Research Scientist
  Georgia Tech College of Computing

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message