httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rudolf Wolf <rudolf.w...@dantax.cz>
Subject Re: Apache 2.0.39 and PHP 4.2.1
Date Fri, 28 Jun 2002 06:34:46 GMT
On Thu, Jun 27, 2002 at 03:36:26PM +0100, Ray Hillman wrote:
> Hi,
> 
> I may have seen this problem, but didn't take it
> in at the time.
> 
> Am I right in assuming that, after building Apache
> 2.0.39 the message on attempting the start the
> server:
> 
> httpd: module "sapi_apache2.c" is not compatible with this version of
> Apache.
> Please contact the vendor for the correct version.
> Unable to start Apache httpd service
> 
> means that I have to wait for PHP 4.3 to
> appear?

I have the same problem and the solution was to recompile PHP. Go to the source directory
of PHP 4.2 and run "make distclean". Then you go to file "php_functions.c" in directory "sapi/apache2filter"
and change the 93rd line from !MODULE_MAGIC... to !AP_MODULE_MAGIC..... Then you should normally
configure and make PHP 4.2.

Ruda Wolf.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message