httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Thoenen <e...@yahoo.com>
Subject odd vhost behavior
Date Tue, 04 Jun 2002 17:07:03 GMT
<!--snip http.conf -->

<VirtualHost 1.2.3.4>
    ServerName sub.domain.tld
    DocumentRoot "C:/Program Files/Apache
Group/Apache/htdocs/sub"
    ServerAdmin me@domain.tld
</VirtualHost>
<VirtualHost 1.2.3.4>
    ServerName domain.tld
    ServerAlias sub.domain.tld
    DocumentRoot "C:/Program Files/Apache
Group/Apache/htdocs/"
    ServerAdmin me@domain.tld
</VirtualHost>

<!-- END SNIP -->

Now what I was hoping happened was any requests for
sub.domain.tld would be answer by sub.domain.tld vhost
and all other requests for ANY_OTHER_RECORD.domain.tld
(or *.domain.tld) would be answered by domain.tld
vhost. Wasn't to sure this was even legit, but it was
the expected behavior (at worst..figured the
*.domain.tld would catch the sub.domain.tld and the
sub.domain.tld would be inaccessible).

What happens though is http://*.domain.tld uses
domain.tld vhost (EXPECTED), http://sub.domain.tld
uses sub.domain.tld vhost (EXPECTED),
http://domain.tld use sub.domain.tld vhost
(UNEXPECTED)

Any ideas why?

Peter

__________________________________________________
Do You Yahoo!?
Yahoo! - Official partner of 2002 FIFA World Cup
http://fifaworldcup.yahoo.com

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message