httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rick Kukiela" <apache-us...@mmhosting.com>
Subject Re: Im about to saw my server in half and use it as fire wood... please help.
Date Wed, 19 Jun 2002 20:58:18 GMT
Doing it the method i depcited here, it is supose to compile the httpd
binary for you. If i try to doit manually it errors out on the mod_perl
module...

rick
----- Original Message -----
From: "Mattias Eriksson" <mattias.eriksson@kdr.ath.cx>
To: <users@httpd.apache.org>
Sent: Wednesday, June 19, 2002 3:55 PM
Subject: SV: Im about to saw my server in half and use it as fire wood...
please help.


> It seems like you have to compile apache before you make "make test" in
> mod_perl?
>
> Becuase it tries to start a test-server?
>
> "../apache_1.3.26/src/httpd: not found"
> ________________
> Mattias Eriksson (sorry for all the swedish in my client)
>
>
> > -----Ursprungligt meddelande-----
> > Från: Rick Kukiela [mailto:apache-users@mmhosting.com]
> > Skickat: den 19 juni 2002 22:50
> > Till: users@httpd.apache.org
> > Ämne: Re: Im about to saw my server in half and use it as fire wood...
> > please help.
> >
> > btw, im running freebsd 4.6 and c-client is setup as per directions
> given
> > for php...
> > i386.
> >
> > Rick
> > ----- Original Message -----
> > From: "Rick Kukiela" <apache-users@mmhosting.com>
> > To: "apache-users" <users@httpd.apache.org>
> > Sent: Wednesday, June 19, 2002 3:46 PM
> > Subject: Im about to saw my server in half and use it as fire wood...
> > please
> > help.
> >
> >
> > > OKAY.......
> > >
> > > My goal in life is to setup apache with php (with imap support and
> mysql
> > > support), with ssl support, and with mod_perl.
> > >
> > > So I download them all to a directory and unpack them
> > >
> > > first i go into apache src and type ./configure
> > > then i go ../php-4.2.1
> > >
> > > then i do
> > >
> > ./configure --with-mysql --with-imap --with-imap-ssl
> --enable-track-vars -
> > -w
> > > ith-apache=../apache-1.3.26
> > >
> > > It configures fine.
> > >
> > > follow with make; make install
> > >
> > > installs fine...
> > >
> > > ok cd ../mod_ssl-xxxx-xxxx
> > > ./configure --with-apache=../apache-1.3.26
> > >
> > > ok works fine.
> > >
> > > cd ../mod_perl-1.26
> > >
> > > perl Makefile.PL USE_APACI=1 EVERYTHING=1 SSL_BASE=SYSTEM
> > > APACHE_PREFIX=/usr/local/apache
> > >
> > APACI_ARGS=--enable-module=ssl,--enable-module=so,--enable-
> > module=rewrite,--
> > > with-ssl=SYSTEM,--activate-module=src/modules/php4/libphp4.a
> > >
> > > ok works fine....
> > >
> > > make test
> > >
> > > BOOMMMBBBBB!!!!!!!!
> > >
> > > This is what I get:
> > >
> > > # make test
> > > cp t/conf/mod_perl_srm.conf t/conf/srm.conf
> > > ../apache_1.3.26/src/httpd -f `pwd`/t/conf/httpd.conf -X -d `pwd`/t
> &
> > > ../apache_1.3.26/src/httpd: not found
> > > httpd listening on port 8529
> > > will write error_log to: t/logs/error_log
> > > letting apache warm up...\c
> > > done
> > > /usr/bin/perl t/TEST 0
> > > still waiting for server to warm up...............not ok
> > > server failed to start! (please examine t/logs/error_log) at t/TEST
> line
> > 95.
> > > *** Error code 9
> > >
> > > Stop in /usr/local/src/mod_perl-1.27.
> > >
> > >
> > >
> > > And the peice of shit doesnt write anything to t/logs/error_log
> infact
> > that
> > > directory is empty.
> > >
> > > What is going on, and how do I fix this, please help some one!!!
> > >
> > >
> > > Thanks in advance,
> > > Rick
> > >
> > >
> > >
> ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> > > For additional commands, e-mail: users-help@httpd.apache.org
> > >
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> > For additional commands, e-mail: users-help@httpd.apache.org
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message