httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "renjin" <ren...@starhub.net.sg>
Subject sh <defunt>
Date Mon, 01 Jul 2002 04:06:48 GMT
hi anyone.
i need a little help on this. been bugged for a week now.
running slackware 7.1.0, apache 1.3.26, php 4.2.1 and mod_perl 1.27

the problem is httpd keeps spawning zombies and after a while the previous httpd processes
will hand and new httpd process will spawn, which in turn create more zombies.
after 3-5 hours, the system will have so many zombies and httpd that no new request will be
entertained and no more web page can be accessed.

ps auxf
root     29059  0.0  0.8  4852 2824 ?        S    11:43   0:00 /usr/local/apache/bin/httpd
nobody   29062  0.0  0.9  4896 3104 ?        S    11:43   0:00  \_ /usr/local/apache/bin/httpd
nobody   29063  0.0  0.9  4876 2916 ?        S    11:43   0:00  \_ /usr/local/apache/bin/httpd
nobody   29064  0.0  0.9  4872 2968 ?        S    11:43   0:00  \_ /usr/local/apache/bin/httpd
nobody   29065  0.0  0.9  4884 2972 ?        S    11:43   0:00  \_ /usr/local/apache/bin/httpd
nobody   29066  0.0  0.9  4896 3096 ?        S    11:43   0:00  \_ /usr/local/apache/bin/httpd
root     30262  0.0  0.0     0    0 ?        Z    11:52   0:00  \_ [sh <defunct>]
root     30263  1.0  0.0     0    0 ?        Z    11:52   0:00  \_ [sh <defunct>]

apache httpd.conf settings are
Timeout 300
KeepAlive On
MaxKeepAliveRequests 100
KeepAliveTimeout 15
MinSpareServers 5
MaxSpareServers 50
StartServers 5
MaxClients 150
MaxRequestsPerChild 0

thanks mil

Mime
View raw message