httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Giorgio Andreoletti" <giorgio.andreole...@mentelocale.it>
Subject Fw: apache 2.0.36 fills up my CPU
Date Mon, 03 Jun 2002 11:29:31 GMT
Hi,
i have a problem with apache filling up my cpu ...

this is my server:
Linux Slackware 8.0 - kernel 2.4.17 - reiserfs
Zope 2.5.1
apache 2.0.36 compiled only with
        ./configure --enable-proxy

The box is a PentiumIII 800MHz, 256MBytes RAM ECC, 2 SCSI HD in raid 1, most
software (included httpd) is installed from sources

Apache is configured to do NameVirtualHosting for about 20 VH, and each
VirtualHost has a ProxyPass to Zope's server (and a ProxyPassReverse); cache
is not enabled

the logfiles don't say anything about something which would 'disturb' my
server, but the fact is that about three times a week one or more httpd
processes goes to the maximun CPU using; the result is that the system
become very slow, but never hangs. The only way to resolve the problem is to
do a
apachectl stop ; killall -9 httpd ; apachectl start

Anyone has any ideas on how can i solve this problem ? I run apache-1.3.20
till last month, and i've never had such this problem; instead, httpd-2.0.36
always gave me this problem. I tried to recompile it, but with no results...

Tnx a lot for your help
have a nice day
Giorgio


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message