httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mattias Eriksson" <mattias.eriks...@kdr.ath.cx>
Subject RE: 2.0.39 problem - module "sapi_apache2.c" is not compatible
Date Wed, 19 Jun 2002 05:50:57 GMT
Have you recompiled the PHP module?

You need to recompile all modules when upgrading apache.
Or is it only version 1.3 you need to do that?

________________
Mattias Eriksson

> [RH 7.2 fully upgraded]
> 
> I'm relatively new to apache.  I had no problem with 2.0.35.
> With 2.0.35, I had no problems with the php module.  The only 3rd
party
> module
> I compiled and installed.
> 
> Tonight, I grabbed the 2.0.39 tarball, and had no problems compiling,
> ./configure --enable-ssl --enable-so, or installing.
> 
> When I tried to start apache, I got the following:
> 
>    [root@localhost httpd-2.0.39]# /usr/local/apache2/bin/apachectl
start
>    httpd: module "sapi_apache2.c" is not compatible with this version
of
> Apache.
> 
> I went through the configure/compile/install process twice to see if
there
> would be a different outcome or an additional informative error
message.
> The outcome was exactly the same.
> 
> So far, I haven't been able to determine where this module is in the
> package
> directories.  And I'm not sure what I would do if/when I find it.
> 
> How do I solve this problem?
> 
> Thank you.
> --
>                             - Martin J. Brown, Jr. -
>                             - mjbjr@beaudesign.com -
> 
>       Public PGP Key ID: 0xDB184F7B keyserver:
http://certserver.pgp.com/


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message